Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1731234

Re: [RFC Part2 PATCH v3 10/26] KVM: Introduce KVM_MEMORY_ENCRYPT_REGISTER/UNREGISTER_RAM ioctl

From Borislav Petkov <bp@suse.de>
Newsgroups linux.kernel
Subject Re: [RFC Part2 PATCH v3 10/26] KVM: Introduce KVM_MEMORY_ENCRYPT_REGISTER/UNREGISTER_RAM ioctl
Date 2017-09-12 23:10 +0200
Message-ID <up0Bt-6wn-29@gated-at.bofh.it> (permalink)
References <u73o5-oR-3@gated-at.bofh.it> <uoZYL-633-23@gated-at.bofh.it> <uoZYL-633-21@gated-at.bofh.it> <up0Bt-6wn-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Sep 12, 2017 at 03:50:55PM -0500, Brijesh Singh wrote:
> Sure, I can do that. In one of the feedback Paolo recommended
> KVM_MEMORY_ENCRYPT_* ioctl name hence I tried to stick with the same name
> for structure. I am flexible to use 'struct enc_region' but I personally
> prefer to keep "mem" somewhere in the structure naming to indicate its for
> *memory* encryption -- maybe struct kvm_mem_enc_region.

I'd drop the "kvm_" prefix: struct mem_enc_region;

But I sense we're bikeshedding here and I'd leave it up to you guys.
My only intent was to shorten those so that they fit on a single line.
In general, I like using small struct names which do not look like
sentences and which give you code that reads quickly, at a glance. But
this is just me.

-- 
Regards/Gruss,
    Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
-- 

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [RFC Part2 PATCH v3 10/26] KVM: Introduce  KVM_MEMORY_ENCRYPT_REGISTER/UNREGISTER_RAM ioctl Borislav Petkov <bp@suse.de> - 2017-09-12 22:30 +0200
  Re: [RFC Part2 PATCH v3 10/26] KVM: Introduce  KVM_MEMORY_ENCRYPT_REGISTER/UNREGISTER_RAM ioctl Borislav Petkov <bp@suse.de> - 2017-09-12 23:10 +0200

csiph-web