Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1728651

Re: [PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by XPFO

From Christoph Hellwig <hch@infradead.org>
Newsgroups linux.kernel
Subject Re: [PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by XPFO
Date 2017-09-08 09:20 +0200
Message-ID <unlK3-3Bf-29@gated-at.bofh.it> (permalink)
References <un8Wu-3e6-13@gated-at.bofh.it> <un8Wu-3e6-31@gated-at.bofh.it> <un9zc-3GP-11@gated-at.bofh.it> <una2e-3SJ-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Sep 07, 2017 at 12:44:14PM -0600, Tycho Andersen wrote:
> On Thu, Sep 07, 2017 at 11:10:15AM -0700, Christoph Hellwig wrote:
> > > -	if (PageHighMem(pfn_to_page(pfn))) {
> > > +	if (PageHighMem(page) || xpfo_page_is_unmapped(page)) {
> > 
> > Please don't sprinkle xpfo details over various bits of code.
> > 
> > Just add a helper with a descriptive name, e.g.
> > 
> > page_is_unmapped()
> > 
> > that also includes the highmem case, as that will easily document
> > what this check is doing.
> 
> Will do, thanks.
> 
> Patch 7 has a similar feel to this one, I can add a wrapper around
> __clean_dcache_area_pou() if that makes sense?

That one is in low-level ARM code so I'm not that worried.
But in general it seems like we should simply have one interface
to check if a page has a kernel mapping or not, nad map/unmap it
if not instead of distinguishing between highmem and xpfo.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by XPFO Tycho Andersen <tycho@docker.com> - 2017-09-07 19:40 +0200
  Re: [PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by  XPFO Christoph Hellwig <hch@infradead.org> - 2017-09-07 20:20 +0200
    Re: [PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by  XPFO Tycho Andersen <tycho@docker.com> - 2017-09-07 20:50 +0200
      Re: [PATCH v6 04/11] swiotlb: Map the buffer if it was unmapped by  XPFO Christoph Hellwig <hch@infradead.org> - 2017-09-08 09:20 +0200

csiph-web