Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1728451

Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue flush

From Byungchul Park <max.byungchul.park@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue flush
Date 2017-09-07 23:30 +0200
Message-ID <uncx4-5G0-21@gated-at.bofh.it> (permalink)
References <umT1n-KQ-9@gated-at.bofh.it> <un1BE-6At-17@gated-at.bofh.it> <un3k5-7L9-7@gated-at.bofh.it> <un6UH-1Tf-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Sep 8, 2017 at 12:21 AM, Peter Zijlstra <peterz@infradead.org> wrote:
> On Thu, Sep 07, 2017 at 08:37:08PM +0900, Byungchul Park wrote:
>> On Thu, Sep 7, 2017 at 6:41 PM, Peter Zijlstra <peterz@infradead.org> wrote:
>> > On Thu, Sep 07, 2017 at 09:33:16AM +0900, Byungchul Park wrote:
>> >> Workqueue added manual acquisitions to catch deadlock cases. Now
>> >> crossrelease was introduced, some of those are redundant because
>> >> crossrelease-enabled wait_for_completeion() also does it. Removed it.
>> >
>> > This does not explain how it doesn't become the regular timing dependent
>> > stuff cross-release normally is.
>>
>> Yes, I will add more explanation for it at the next spin.
>>
>> But, let me explain it a bit here to help you get it, since it's very
>> simple. This has nothing to do with 'might' thing I introduced
>> previously. For 'might' thing, I will start it after getting your response.
>>
>> Here, I just removed acquire() because wait_for_completion()
>> already includes the acquire() by LOCKDEP_COMPLETIONS.
>> That's all.
>
> Ah I see, but it does so using some fairly nasty completion init stuff.
> The old code was far easier to read.

Agree.

But, old code has redundant acquisitions, moreover uses sub-class
to avoid false detection, even though they are the same class.

I will try to enhance readability of completion init, and fix the incorrect
use at the next spin.

-- 
Thanks,
Byungchul

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue flush Byungchul Park <byungchul.park@lge.com> - 2017-09-07 02:40 +0200
  Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue  flush Peter Zijlstra <peterz@infradead.org> - 2017-09-07 11:50 +0200
    Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue flush Byungchul Park <max.byungchul.park@gmail.com> - 2017-09-07 13:40 +0200
      Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue  flush Peter Zijlstra <peterz@infradead.org> - 2017-09-07 17:30 +0200
        Re: [PATCH] lockdep: Remove unnecessary acquisitions wrt workqueue flush Byungchul Park <max.byungchul.park@gmail.com> - 2017-09-07 23:30 +0200

csiph-web