Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1727031
| From | Borislav Petkov <bp@suse.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC Part2 PATCH v3 01/26] Documentation/virtual/kvm: Add AMD Secure Encrypted Virtualization (SEV) |
| Date | 2017-09-06 00:10 +0200 |
| Message-ID | <umucG-oz-29@gated-at.bofh.it> (permalink) |
| References | <u73o5-oR-3@gated-at.bofh.it> <umpPH-5JK-9@gated-at.bofh.it> <umpPH-5JK-7@gated-at.bofh.it> <umucG-oz-31@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Sep 05, 2017 at 04:39:14PM -0500, Brijesh Singh wrote:
> I was trying map with SEV firmware spec command names but I see your
> point and will call it "KVM_SEV_GET_GUEST_STATUS".
>
>
> > > +
> > > +enum {
> > > + /* guest state is not known */
> > > + SEV_STATE_INVALID = 0;
> >
> > not known or invalid?
>
>
> Again, was trying to follow the spec naming convention but I can go
> with UNKNOWN ..
Yeah, but they will now differ from the spec, which weakens my point
considerably. I guess using KVM_SEV_<spec_name> everywhere is the
optimal solution for the commands and the SEV_STATE_<spec_name> for the
states.
Because having them differ from the spec - esp. for the sake of some
more precise naming - is worse. IMO, of course.
--
Regards/Gruss,
Boris.
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
--
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [RFC Part2 PATCH v3 01/26] Documentation/virtual/kvm: Add AMD Secure Encrypted Virtualization (SEV) Borislav Petkov <bp@suse.de> - 2017-09-05 19:30 +0200 Re: [RFC Part2 PATCH v3 01/26] Documentation/virtual/kvm: Add AMD Secure Encrypted Virtualization (SEV) Borislav Petkov <bp@suse.de> - 2017-09-06 00:10 +0200 Re: [RFC Part2 PATCH v3 01/26] Documentation/virtual/kvm: Add AMD Secure Encrypted Virtualization (SEV) Borislav Petkov <bp@suse.de> - 2017-09-06 18:50 +0200
csiph-web