Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1719584
| From | Philipp Reisner <philipp.reisner@linbit.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/17] DRBD updates |
| Date | 2017-08-24 23:30 +0200 |
| Message-ID | <ui7Rn-3tg-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Hi Jens, Please consider these patches for your for-4.14 branch. The first and third patch help with request merging on DRBD's secondary side. That can improves performance for some workloads. The other patches are fixes and random mentenance. Baoyou Xie (1): drbd: mark symbols static where possible Geliang Tang (1): drbd: Use setup_timer() instead of init_timer() to simplify the code. Greg Kroah-Hartman (1): drbd: rename "usermode_helper" to "drbd_usermode_helper" Lars Ellenberg (9): drbd: introduce drbd_recv_header_maybe_unplug drbd: change list_for_each_safe to while(list_first_entry_or_null) drbd: add explicit plugging when submitting batches drbd: Send P_NEG_ACK upon write error in protocol != C drbd: new disk-option disable-write-same drbd: fix potential get_ldev/put_ldev refcount imbalance during attach drbd: fix rmmod cleanup, remove _all_ debugfs entries drbd: fix potential deadlock when trying to detach during handshake drbd: fix race between handshake and admin disconnect/down Markus Elfring (1): drbd: A single dot should be put into a sequence. Philipp Reisner (1): drbd: Fix resource role for newly created resources in events2 Roland Kammerer (3): drbd: move global variables to drbd namespace and make some static drbd: abort drbd_start_resync if there is no connection drbd: switch from kmalloc() to kmalloc_array() drivers/block/drbd/drbd_int.h | 27 +++++----- drivers/block/drbd/drbd_main.c | 106 +++++++++++++++++++++---------------- drivers/block/drbd/drbd_nl.c | 60 +++++++++------------ drivers/block/drbd/drbd_proc.c | 10 ++-- drivers/block/drbd/drbd_receiver.c | 56 +++++++++++++++++--- drivers/block/drbd/drbd_req.c | 80 ++++++++++++++++++++++++++-- drivers/block/drbd/drbd_req.h | 6 +++ drivers/block/drbd/drbd_state.c | 48 ++++++++++++++++- drivers/block/drbd/drbd_state.h | 8 +++ drivers/block/drbd/drbd_worker.c | 46 ++++++++++++---- include/linux/drbd.h | 2 +- include/linux/drbd_genl.h | 3 +- include/linux/drbd_limits.h | 8 ++- 13 files changed, 333 insertions(+), 127 deletions(-) -- 2.7.4
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/17] DRBD updates Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 12/17] drbd: fix potential deadlock when trying to detach during handshake Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 04/17] drbd: Send P_NEG_ACK upon write error in protocol != C Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 03/17] drbd: add explicit plugging when submitting batches Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 05/17] drbd: mark symbols static where possible Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 02/17] drbd: change list_for_each_safe to while(list_first_entry_or_null) Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
Re: [PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Jens Axboe <axboe@kernel.dk> - 2017-08-25 19:30 +0200
Re: [PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-28 15:40 +0200
[PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-28 16:00 +0200
[PATCH 08/17] drbd: fix potential get_ldev/put_ldev refcount imbalance during attach Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 17/17] drbd: switch from kmalloc() to kmalloc_array() Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 07/17] drbd: new disk-option disable-write-same Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 15/17] drbd: move global variables to drbd namespace and make some static Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 16/17] drbd: abort drbd_start_resync if there is no connection Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 13/17] drbd: fix race between handshake and admin disconnect/down Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
[PATCH 10/17] drbd: fix rmmod cleanup, remove _all_ debugfs entries Philipp Reisner <philipp.reisner@linbit.com> - 2017-08-24 23:30 +0200
csiph-web