Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1719277
| From | Dan Carpenter <dan.carpenter@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] staging:rtl8188eu:core Fix Avoid CamelCase |
| Date | 2017-08-24 16:20 +0200 |
| Message-ID | <ui19g-7EU-11@gated-at.bofh.it> (permalink) |
| References | <uhWMh-4E5-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Aug 24, 2017 at 02:58:06PM +0530, Janani Sankara Babu wrote: > This patch is created to solve the CamelCase issue. The members 'IEs' and > 'IELength' of struct wlan_bssid_ex are being modified to 'ies' and > 'ie_length' to solve the issue. And all the places where these variables > are referenced inside the rtl8188eu driver are also changed. > > Signed-off-by: Janani Sankara Babu <jananis37@gmail.com> > --- > drivers/staging/rtl8188eu/core/rtw_ap.c | 89 +++++++++++---------- > drivers/staging/rtl8188eu/core/rtw_cmd.c | 26 +++--- > drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 20 ++--- > drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 2 +- > drivers/staging/rtl8188eu/core/rtw_mlme.c | 66 ++++++++-------- > drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 100 ++++++++++++------------ > drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 34 ++++---- > drivers/staging/rtl8188eu/hal/rtl8188e_cmd.c | 16 ++-- > drivers/staging/rtl8188eu/include/wlan_bssdef.h | 10 +-- > drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 12 +-- > 10 files changed, 189 insertions(+), 186 deletions(-) > > diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c b/drivers/staging/rtl8188eu/core/rtw_ap.c > index 647a922..2cd20f1 100644 > --- a/drivers/staging/rtl8188eu/core/rtw_ap.c > +++ b/drivers/staging/rtl8188eu/core/rtw_ap.c > @@ -69,19 +69,22 @@ static void update_BCNTIM(struct adapter *padapter) > struct mlme_ext_priv *pmlmeext = &padapter->mlmeextpriv; > struct mlme_ext_info *pmlmeinfo = &pmlmeext->mlmext_info; > struct wlan_bssid_ex *pnetwork_mlmeext = &pmlmeinfo->network; > - unsigned char *pie = pnetwork_mlmeext->IEs; > + //unsigned char *pie = pnetwork_mlmeext->ies; > + unsigned char *pie = pnetwork_mlmeext->ies; Why did you comment this out? Really "ie" is a better name that "ies". The "s" was supposed to make it plural but that's not obvious in the new code. regards, dan carpenter
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH] staging:rtl8188eu:core Fix Avoid CamelCase Dan Carpenter <dan.carpenter@oracle.com> - 2017-08-24 16:20 +0200
csiph-web