Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1717660
| From | Hannes Frederic Sowa <hannes@stressinduktion.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] once: switch to new jump label API |
| Date | 2017-08-22 20:50 +0200 |
| Message-ID | <uhmpr-6fC-3@gated-at.bofh.it> (permalink) |
| References | <uh4Cd-2u0-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Eric Biggers <ebiggers3@gmail.com> writes: > From: Eric Biggers <ebiggers@google.com> > > Switch the DO_ONCE() macro from the deprecated jump label API to the new > one. The new one is more readable, and for DO_ONCE() it also makes the > generated code more icache-friendly: now the one-time initialization > code is placed out-of-line at the jump target, rather than at the inline > fallthrough case. > > Signed-off-by: Eric Biggers <ebiggers@google.com> Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org. Thanks!
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] once: switch to new jump label API Eric Biggers <ebiggers3@gmail.com> - 2017-08-22 01:50 +0200 Re: [PATCH] once: switch to new jump label API Hannes Frederic Sowa <hannes@stressinduktion.org> - 2017-08-22 20:50 +0200
csiph-web