Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1716759

Re: [PATCH 4/6] dpaa_eth: add NETIF_F_RXHASH

From David Miller <davem@davemloft.net>
Newsgroups linux.kernel
Subject Re: [PATCH 4/6] dpaa_eth: add NETIF_F_RXHASH
Date 2017-08-21 20:00 +0200
Message-ID <ugZ9v-7pX-13@gated-at.bofh.it> (permalink)
References <ugZ9v-7pX-15@gated-at.bofh.it> <ugZ9v-7pX-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Madalin Bucur <madalin.bucur@nxp.com>
Date: Fri, 18 Aug 2017 11:56:26 +0300

> +	if (net_dev->features & NETIF_F_RXHASH && priv->keygen_in_use &&
> +	    !fman_port_get_hash_result_offset(priv->mac_dev->port[RX],
> +					      &hash_offset))
> +		skb_set_hash(skb, be32_to_cpu(*(u32 *)(vaddr + hash_offset)),
> +			     // if L4 exists, it was used in the hash generation
> +			     be32_to_cpu(fd->status) & FM_FD_STAT_L4CV ?
> +				PKT_HASH_TYPE_L4 : PKT_HASH_TYPE_L3);

We do not use "//" c++ style comments in the kernel.

And putting a comment right in the middle of a set of arguments being
passed to a function makes the code harder to read, so please do not
do this.

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH 4/6] dpaa_eth: add NETIF_F_RXHASH David Miller <davem@davemloft.net> - 2017-08-21 20:00 +0200

csiph-web