Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1716564
| From | Joe Lawrence <joe.lawrence@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v5] shadow variables |
| Date | 2017-08-21 16:50 +0200 |
| Message-ID | <ugWbE-5BL-13@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
v5:
- Adopt Petr's suggested combined __klp_shadow_get_or_attach() routine
- API
- s/klp_shadow_attach/klp_shadow_alloc/g
- s/klp_shadow_get_or_attach/klp_shadow_get_or_alloc/g
- s/klp_shadow_detach/klp_shadow_free/g
- remove klp_shadow_update_or_attach()
- Code comments
- Add Petr's description for klp_shadow_get_or_alloc()
- Swap paragraphs in klp_shadow_alloc() description
- Add short description of klp_shadow_lock
- Remove incorrect klp_shadow_lock comment in klp_shadow_match() and
klp_shadow_set()
- Add a use-after-free disclaimer to klp_shadow_free() and
klp_shadow_free_all()
- Samples: Fix use-after-free in memory leak fix modules
- Doc: Simplify code in sta_info_free() use-case
Joe Lawrence (1):
livepatch: introduce shadow variable API
Documentation/livepatch/shadow-vars.txt | 191 +++++++++++++++++++
include/linux/livepatch.h | 8 +
kernel/livepatch/Makefile | 2 +-
kernel/livepatch/shadow.c | 296 ++++++++++++++++++++++++++++++
samples/Kconfig | 5 +-
samples/livepatch/Makefile | 3 +
samples/livepatch/livepatch-shadow-fix1.c | 173 +++++++++++++++++
samples/livepatch/livepatch-shadow-fix2.c | 168 +++++++++++++++++
samples/livepatch/livepatch-shadow-mod.c | 224 ++++++++++++++++++++++
9 files changed, 1066 insertions(+), 4 deletions(-)
create mode 100644 Documentation/livepatch/shadow-vars.txt
create mode 100644 kernel/livepatch/shadow.c
create mode 100644 samples/livepatch/livepatch-shadow-fix1.c
create mode 100644 samples/livepatch/livepatch-shadow-fix2.c
create mode 100644 samples/livepatch/livepatch-shadow-mod.c
--
1.8.3.1
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v5] shadow variables Joe Lawrence <joe.lawrence@redhat.com> - 2017-08-21 16:50 +0200
[PATCH v5] livepatch: introduce shadow variable API Joe Lawrence <joe.lawrence@redhat.com> - 2017-08-21 16:50 +0200
Re: [PATCH v5] livepatch: introduce shadow variable API Josh Poimboeuf <jpoimboe@redhat.com> - 2017-08-22 20:40 +0200
csiph-web