Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1709852
| From | Brian Norris <briannorris@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] ASoC: hdmi-codec: Use different name for playback streams |
| Date | 2017-08-11 19:00 +0200 |
| Message-ID | <udlrZ-5XG-25@gated-at.bofh.it> (permalink) |
| References | <uddup-1aP-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Jeffy,
You need to be more careful about the addressee's of your patches. No
one on To/CC is a maintainer or a sufficiently-targeted mailing list. I
doubt any of the maintainers will read your patch. (I've added
alsa-devel for you, but given my understanding of at least Mark's
patchwork workflow -- and of general patch etiquette -- it's important
the patch is actually sent there in the first place.)
Probably worth resending.
Brian
On Fri, Aug 11, 2017 at 04:29:33PM +0800, Jeffy Chen wrote:
> Currently the hdmi i2s playback stream and hdmi spdif playback stream
> are using the same name. So when they are enabled at the same time,
> kernel will print this warning:
>
> [ 2.201835] hdmi-audio-codec hdmi-audio-codec.1.auto: ASoC: Failed to
> create Playback debugfs file
>
> Assign different names to them to avoid that.
>
> Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
> ---
>
> sound/soc/codecs/hdmi-codec.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/sound/soc/codecs/hdmi-codec.c b/sound/soc/codecs/hdmi-codec.c
> index 509ab51..a2af440 100644
> --- a/sound/soc/codecs/hdmi-codec.c
> +++ b/sound/soc/codecs/hdmi-codec.c
> @@ -696,7 +696,7 @@ static struct snd_soc_dai_driver hdmi_i2s_dai = {
> .name = "i2s-hifi",
> .id = DAI_ID_I2S,
> .playback = {
> - .stream_name = "Playback",
> + .stream_name = "I2S Playback",
> .channels_min = 2,
> .channels_max = 8,
> .rates = HDMI_RATES,
> @@ -711,7 +711,7 @@ static const struct snd_soc_dai_driver hdmi_spdif_dai = {
> .name = "spdif-hifi",
> .id = DAI_ID_SPDIF,
> .playback = {
> - .stream_name = "Playback",
> + .stream_name = "SPDIF Playback",
> .channels_min = 2,
> .channels_max = 2,
> .rates = HDMI_RATES,
> --
> 2.1.4
>
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] ASoC: hdmi-codec: Use different name for playback streams Jeffy Chen <jeffy.chen@rock-chips.com> - 2017-08-11 10:30 +0200
Re: [PATCH] ASoC: hdmi-codec: Use different name for playback streams Brian Norris <briannorris@chromium.org> - 2017-08-11 19:00 +0200
Re: [PATCH] ASoC: hdmi-codec: Use different name for playback streams jeffy <jeffy.chen@rock-chips.com> - 2017-08-12 03:00 +0200
csiph-web