Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1707266
| From | Laurent Dufour <ldufour@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 02/16] mm: Prepare for FAULT_FLAG_SPECULATIVE |
| Date | 2017-08-09 13:00 +0200 |
| Message-ID | <ucwSu-61x-9@gated-at.bofh.it> (permalink) |
| References | <ucdPQ-1fE-5@gated-at.bofh.it> <ucdPQ-1fE-15@gated-at.bofh.it> <ucw66-5Jg-37@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 09/08/2017 12:08, Kirill A. Shutemov wrote:
> On Tue, Aug 08, 2017 at 04:35:35PM +0200, Laurent Dufour wrote:
>> @@ -2295,7 +2302,11 @@ static int wp_page_copy(struct vm_fault *vmf)
>> /*
>> * Re-check the pte - we dropped the lock
>> */
>> - vmf->pte = pte_offset_map_lock(mm, vmf->pmd, vmf->address, &vmf->ptl);
>> + if (!pte_map_lock(vmf)) {
>> + mem_cgroup_cancel_charge(new_page, memcg, false);
>> + ret = VM_FAULT_RETRY;
>> + goto oom_free_new;
>
> With the change, label is misleading.
That's right.
But I'm wondering renaming it out to 'out_free_new' and replacing all the
matching 'goto' where the label was making sense will help readability ?
Have you better idea ?
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 02/16] mm: Prepare for FAULT_FLAG_SPECULATIVE Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2017-08-08 16:40 +0200
Re: [PATCH 02/16] mm: Prepare for FAULT_FLAG_SPECULATIVE "Kirill A. Shutemov" <kirill@shutemov.name> - 2017-08-09 12:10 +0200
Re: [PATCH 02/16] mm: Prepare for FAULT_FLAG_SPECULATIVE Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2017-08-09 13:00 +0200
csiph-web