Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1701613

Re: [PATCH v2 1/4] mm: refactoring TLB gathering API

From Minchan Kim <minchan@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2 1/4] mm: refactoring TLB gathering API
Date 2017-08-02 03:00 +0200
Message-ID <u9Qb0-2LB-15@gated-at.bofh.it> (permalink)
References <u9ynL-7J1-5@gated-at.bofh.it> <u9ynL-7J1-11@gated-at.bofh.it> <u9CKL-2Ig-43@gated-at.bofh.it> <u9Q1j-2Gs-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi Nadav,

On Tue, Aug 01, 2017 at 05:46:14PM -0700, Nadav Amit wrote:
> Mel Gorman <mgorman@techsingularity.net> wrote:
> 
> > On Tue, Aug 01, 2017 at 02:56:14PM +0900, Minchan Kim wrote:
> >> This patch is ready for solving race problems caused by TLB batch.
> > 
> > s/is ready/is a preparatory patch/
> > 
> >> For that, we will increase/decrease TLB flush pending count of
> >> mm_struct whenever tlb_[gather|finish]_mmu is called.
> >> 
> >> Before making it simple, this patch separates architecture specific
> >> part and rename it to arch_tlb_[gather|finish]_mmu and generic part
> >> just calls it.
> >> 
> >> It shouldn't change any behavior.
> >> 
> >> Cc: Ingo Molnar <mingo@redhat.com>
> >> Cc: Russell King <linux@armlinux.org.uk>
> >> Cc: Tony Luck <tony.luck@intel.com>
> >> Cc: Martin Schwidefsky <schwidefsky@de.ibm.com>
> >> Cc: "David S. Miller" <davem@davemloft.net>
> >> Cc: Heiko Carstens <heiko.carstens@de.ibm.com>
> >> Cc: Yoshinori Sato <ysato@users.sourceforge.jp>
> >> Cc: Jeff Dike <jdike@addtoit.com>
> >> Cc: linux-arch@vger.kernel.org
> >> Cc: Nadav Amit <nadav.amit@gmail.com>
> >> Cc: Mel Gorman <mgorman@techsingularity.net>
> >> Signed-off-by: Minchan Kim <minchan@kernel.org>
> > 
> > You could alias arch_generic_tlb_finish_mmu as arch_tlb_gather_mmu
> > simiilar to how other arch-generic helpers are done to avoid some
> > #ifdeffery but otherwise
> 
> Minchan,
> 
> Andrew wishes me to send one series that combines both series. What about
> this comment from Mel? It seems you intentionally did not want to alias
> them...

It was not intentional but just forgot it. :(
I really appreciate if you could do for me. :)

> 
> BTW: patch 4 should add “#include <asm/tlb.h>" - I’ll add it. 

Thanks!

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 1/4] mm: refactoring TLB gathering API Minchan Kim <minchan@kernel.org> - 2017-08-01 08:00 +0200
  Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Mel Gorman <mgorman@techsingularity.net> - 2017-08-01 12:40 +0200
    Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Nadav Amit <nadav.amit@gmail.com> - 2017-08-02 02:50 +0200
      Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Minchan Kim <minchan@kernel.org> - 2017-08-02 03:00 +0200
    Re: [PATCH v2 1/4] mm: refactoring TLB gathering API Minchan Kim <minchan@kernel.org> - 2017-08-02 03:00 +0200

csiph-web