Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1697459
| From | Daniel Micay <danielmicay@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] fortify: Use WARN instead of BUG for now |
| Date | 2017-07-26 20:00 +0200 |
| Message-ID | <u7yLh-3p3-33@gated-at.bofh.it> (permalink) |
| References | <u7lEm-3wP-3@gated-at.bofh.it> <u7u4V-qb-13@gated-at.bofh.it> <u7yif-3eE-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> Maybe we could do two phases? One to s/BUG/WARN/ and the second to > improve the message? s/fortify_panic/fortify_overflow/ + use WARN + remove __noreturn makes sense as one commit. Still think the *option* of __noreturn + BUG should be kept there even just for measuring the size overhead. !COMPILE_TIME && EXPERT if it needs to be for now. If you're fully removing __noreturn then the entry in tools/objtool/check.c for __noreturn functions also won't make sense (either way it needs to use the new name). I think improving error messages should be done a bit differently though and it'll be easier to not tie these things together.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] fortify: Use WARN instead of BUG for now Kees Cook <keescook@chromium.org> - 2017-07-26 06:00 +0200
Re: [PATCH] fortify: Use WARN instead of BUG for now Daniel Micay <danielmicay@gmail.com> - 2017-07-26 15:00 +0200
Re: [PATCH] fortify: Use WARN instead of BUG for now Kees Cook <keescook@chromium.org> - 2017-07-26 19:30 +0200
Re: [PATCH] fortify: Use WARN instead of BUG for now Daniel Micay <danielmicay@gmail.com> - 2017-07-26 20:00 +0200
Re: [PATCH] fortify: Use WARN instead of BUG for now Linus Torvalds <torvalds@linux-foundation.org> - 2017-07-26 19:20 +0200
Re: [PATCH] fortify: Use WARN instead of BUG for now Kees Cook <keescook@chromium.org> - 2017-07-26 19:20 +0200
csiph-web