Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1696527
| From | Vikas Shivappa <vikas.shivappa@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 20/28] x86/intel_rdt: Separate the ctrl bits from rmdir |
| Date | 2017-07-25 23:20 +0200 |
| Message-ID | <u7fph-86t-71@gated-at.bofh.it> (permalink) |
| References | <u7fpf-86t-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Re-factor the code to separate the ctrl group removal from the rmdir to
prepare to add RDT monitoring group removal.
Signed-off-by: Vikas Shivappa <vikas.shivappa@linux.intel.com>
---
arch/x86/kernel/cpu/intel_rdt_rdtgroup.c | 48 ++++++++++++++++++++++----------
1 file changed, 33 insertions(+), 15 deletions(-)
diff --git a/arch/x86/kernel/cpu/intel_rdt_rdtgroup.c b/arch/x86/kernel/cpu/intel_rdt_rdtgroup.c
index 8f9b54e..59251592 100644
--- a/arch/x86/kernel/cpu/intel_rdt_rdtgroup.c
+++ b/arch/x86/kernel/cpu/intel_rdt_rdtgroup.c
@@ -1568,20 +1568,10 @@ static int rdtgroup_mkdir(struct kernfs_node *parent_kn, const char *name,
return -EPERM;
}
-static int rdtgroup_rmdir(struct kernfs_node *kn)
+static int rdtgroup_rmdir_ctrl(struct kernfs_node *kn, struct rdtgroup *rdtgrp,
+ cpumask_var_t tmpmask)
{
- int ret, cpu, closid = rdtgroup_default.closid;
- struct rdtgroup *rdtgrp;
- cpumask_var_t tmpmask;
-
- if (!zalloc_cpumask_var(&tmpmask, GFP_KERNEL))
- return -ENOMEM;
-
- rdtgrp = rdtgroup_kn_lock_live(kn);
- if (!rdtgrp) {
- ret = -EPERM;
- goto out;
- }
+ int cpu;
/* Give any tasks back to the default group */
rdt_move_group_tasks(rdtgrp, &rdtgroup_default, tmpmask);
@@ -1592,7 +1582,7 @@ static int rdtgroup_rmdir(struct kernfs_node *kn)
/* Update per cpu closid of the moved CPUs first */
for_each_cpu(cpu, &rdtgrp->cpu_mask)
- per_cpu(rdt_cpu_default.closid, cpu) = closid;
+ per_cpu(rdt_cpu_default.closid, cpu) = rdtgroup_default.closid;
/*
* Update the MSR on moved CPUs and CPUs which have moved
* task running on them.
@@ -1610,7 +1600,35 @@ static int rdtgroup_rmdir(struct kernfs_node *kn)
*/
kernfs_get(kn);
kernfs_remove(rdtgrp->kn);
- ret = 0;
+
+ return 0;
+}
+
+static int rdtgroup_rmdir(struct kernfs_node *kn)
+{
+ struct kernfs_node *parent_kn = kn->parent;
+ struct rdtgroup *rdtgrp;
+ cpumask_var_t tmpmask;
+ int ret = 0;
+
+ if (!zalloc_cpumask_var(&tmpmask, GFP_KERNEL))
+ return -ENOMEM;
+
+ rdtgrp = rdtgroup_kn_lock_live(kn);
+ if (!rdtgrp) {
+ ret = -EPERM;
+ goto out;
+ }
+
+ /*
+ * If the rdtgroup is a ctrl_mon group and parent directory
+ * is the root directory, remove the ctrl group.
+ */
+ if (rdtgrp->type == RDTCTRL_GROUP && parent_kn == rdtgroup_default.kn)
+ ret = rdtgroup_rmdir_ctrl(kn, rdtgrp, tmpmask);
+ else
+ ret = -EPERM;
+
out:
rdtgroup_kn_unlock(kn);
free_cpumask_var(tmpmask);
--
1.9.1
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/28 V2] Cqm3 patch series(along with MBM support) Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 03/28] x86/intel_rdt: Introduce a common compile option for RDT Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 05/28] x86/intel_rdt: Mark rdt_root and closid_alloc as static Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 07/28] x86/intel_rdt: make rdt_resources_all more readable Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 04/28] x86/intel_rdt: Change file names to accommodate RDT monitor code Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 21/28] x86/intel_rdt/cqm: Add rmdir support Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 06/28] x86/intel_rdt: Cleanup namespace to support RDT monitoring Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 14/28] x86/intel_rdt: Change closid type from int to u32 Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 20/28] x86/intel_rdt: Separate the ctrl bits from rmdir Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 22/28] x86/intel_rdt/cqm: Add mount,umount support Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 09/28] x86/intel_rdt/cqm: Add RMID(Resource monitoring ID) management Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 16/28] x86/intel_rdt: Prepare to add RDT monitor cpus file support Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH 13/28] x86/intel_rdt/cqm: Add mkdir support for RDT monitoring Vikas Shivappa <vikas.shivappa@linux.intel.com> - 2017-07-25 23:20 +0200 [PATCH] x86/intel_rdt: Show bitmask of shareable resource with other executing units "Luck, Tony" <tony.luck@intel.com> - 2017-07-26 00:40 +0200 [RFC PATCH] Add "-f" and "-F" flags to watch a "/sys? style file (single number) "Luck, Tony" <tony.luck@intel.com> - 2017-07-26 00:50 +0200
csiph-web