Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1698328
| Path | csiph.com!eternal-september.org!feeder.eternal-september.org!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Franklin S Cooper Jr <fcooper@ti.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings |
| Date | Thu, 27 Jul 2017 23:20:01 +0200 |
| Message-ID | <u7Yml-2WL-15@gated-at.bofh.it> (permalink) |
| References | <u6UE9-3ig-11@gated-at.bofh.it> <u6UEa-3ig-25@gated-at.bofh.it> <u7xFv-2JL-7@gated-at.bofh.it> <u7xYS-37A-15@gated-at.bofh.it> <u7zei-3PM-17@gated-at.bofh.it> <u7W1c-1e4-19@gated-at.bofh.it> |
| X-Original-To | Oliver Hartkopp <socketcan@hartkopp.net>, Andrew Lunn <andrew@lunn.ch> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/simple; d=ti.com; s=ti-com-17Q1; t=1501189819; bh=/zKwNMSfQyJqQbCuVK1j/ZN7jWCsXAlSH9t/Yn6LPzg=; h=Subject:To:References:CC:From:Date:In-Reply-To; b=w26wbmYQvsMytrq6MDuvpbWFOpuD15tXNJNQbtBigFx/wRe+XQdSQS4EVWGhMCfSE l2iVylFmhkbnKiB/TwjVqgJ5/wnA9Utx48WYcl1MltoJup0PgsrL1f84eFX+jSefd8 W0/od04eVG40iK5/FVpYhBtGB0G39G1Obz7IKQb4= |
| User-Agent | Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.8.0 |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset="windows-1252" |
| Content-Transfer-Encoding | 7bit |
| X-Originating-IP | [128.247.59.33] |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 73 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | <linux-kernel@vger.kernel.org>, <devicetree@vger.kernel.org>, <netdev@vger.kernel.org>, <linux-can@vger.kernel.org>, <wg@grandegger.com>, <mkl@pengutronix.de>, <robh+dt@kernel.org>, <quentin.schulz@free-electrons.com>, <dev.kurt@vandijck-laurijssen.be>, <sergei.shtylyov@cogentembedded.com> |
| X-Original-Date | Thu, 27 Jul 2017 16:10:14 -0500 |
| X-Original-Message-ID | <932602fe-d06a-7a17-5a0c-24265cf2e643@ti.com> |
| X-Original-References | <20170724230521.1436-1-fcooper@ti.com> <20170724230521.1436-3-fcooper@ti.com> <20170726164124.GL12049@lunn.ch> <355b90b3-97ce-1057-6617-d5d709449c48@hartkopp.net> <a77fe395-33c7-9405-b51a-5d3372e5c58b@ti.com> <fe99189e-d077-ba65-4dfc-a4d8beee62b3@hartkopp.net> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1698328 |
Show key headers only | View raw
On 07/27/2017 01:47 PM, Oliver Hartkopp wrote: > On 07/26/2017 08:29 PM, Franklin S Cooper Jr wrote: >> > >> I'm fine with switching to using bitrate instead of speed. Kurk was >> originally the one that suggested to use the term arbitration and data >> since thats how the spec refers to it. Which I do agree with. But your >> right that in the drivers (struct can_priv) we just use bittiming and >> data_bittiming (CAN-FD timings). I don't think adding "fd" into the >> property name makes sense unless we are calling it something like >> "max-canfd-bitrate" which I would agree is the easiest to understand. >> >> So what is the preference if we end up sticking with two properties? >> Option 1 or 2? >> >> 1) >> max-bitrate >> max-data-bitrate >> >> 2) >> max-bitrate >> max-canfd-bitrate >> >> > > 1 > >>> A CAN transceiver is limited in bandwidth. But you only have one RX and >>> one TX line between the CAN controller and the CAN transceiver. The >>> transceiver does not know about CAN FD - it has just a physical(!) layer >>> with a limited bandwidth. This is ONE limitation. >>> >>> So I tend to specify only ONE 'max-bitrate' property for the >>> fixed-transceiver binding. >>> >>> The fact whether the CAN controller is CAN FD capable or not is provided >>> by the netlink configuration interface for CAN controllers. >> >> Part of the reasoning to have two properties is to indicate that you >> don't support CAN FD while limiting the "arbitration" bit rate. > > ?? > > It's a physical layer device which only has a bandwidth limitation. > The transceiver does not know about CAN FD. > >> With one >> property you can not determine this and end up having to make some >> assumptions that can quickly end up biting people. > > Despite the fact that the transceiver does not know anything about ISO > layer 2 (CAN/CAN FD) the properties should look like > > max-bitrate > canfd-capable > > then. > > But when the tranceiver is 'canfd-capable' agnostic, why provide a > property for it? > > Maybe I'm wrong but I still can't follow your argumentation ideas. Your right. I spoke to our CAN transceiver team and I finally get your points. So yes using "max-bitrate" alone is all we need. Sorry for the confusion and I'll create a new rev using this approach. > > Regards, > Oliver
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr <fcooper@ti.com> - 2017-07-25 01:10 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Oliver Hartkopp <socketcan@hartkopp.net> - 2017-07-25 18:40 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr <fcooper@ti.com> - 2017-07-25 20:20 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Andrew Lunn <andrew@lunn.ch> - 2017-07-26 18:50 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Oliver Hartkopp <socketcan@hartkopp.net> - 2017-07-26 19:10 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr <fcooper@ti.com> - 2017-07-26 20:30 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Oliver Hartkopp <socketcan@hartkopp.net> - 2017-07-27 20:50 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr <fcooper@ti.com> - 2017-07-27 23:20 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be> - 2017-07-28 07:00 +0200
Re: [PATCH v2 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Oliver Hartkopp <socketcan@hartkopp.net> - 2017-07-28 10:50 +0200
csiph-web