Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1694504
| From | Dan Carpenter <dan.carpenter@oracle.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/3] staging: pi433: - style fix, space before tabs |
| Date | 2017-07-24 09:50 +0200 |
| Message-ID | <u6GhP-1Ow-15@gated-at.bofh.it> (permalink) |
| References | <u5TKa-5cO-9@gated-at.bofh.it> <u5YgN-89g-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, Jul 22, 2017 at 10:48:24AM +0200, Marcus Wolf wrote:
> Reviewed-by: Marcus Wolf <linux@wolf-entwicklungen.de>
>
> >From my point of view, the rearrangement of the block of SET_CHECKED reduces the
> readability a lot. I like same stuff to be aligned (all brakets below each other
> as a column, all spi->dev below each other and so on) But if it is necessary to
> fullfill the rules, we have to do it the new way.
It's not necessary. The rule is just complaining about this:
SET_CHECKED(rf69_set_bandwidth (dev->spi, rx_cfg->bw_mantisse, rx_cfg->bw_exponent));
^
There is a space after the 'h' character. The old code has
"[space][tab][tab][space](dev->spi,..." it should be:
"[tab][tab][space](dev->spi, ..."
Also the rules are there to improve readability. Sometimes they're
debatable but if they make readability worse, then we can ignore the
rules.
regards,
dan carpenter
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 2/3] staging: pi433: - style fix, space before tabs Derek Robson <robsonde@gmail.com> - 2017-07-22 06:00 +0200
Re: [PATCH 2/3] staging: pi433: - style fix, space before tabs Marcus Wolf <marcus.wolf@wolf-entwicklungen.de> - 2017-07-22 10:50 +0200
Re: [PATCH 2/3] staging: pi433: - style fix, space before tabs Dan Carpenter <dan.carpenter@oracle.com> - 2017-07-24 09:50 +0200
csiph-web