Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1692690

Re: [PATCH v1 1/7] drm/stm: drv: Rename platform driver name

From Benjamin Gaignard <benjamin.gaignard@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH v1 1/7] drm/stm: drv: Rename platform driver name
Date 2017-07-20 11:30 +0200
Message-ID <u5fWr-5m0-35@gated-at.bofh.it> (permalink)
References <u4xVo-1aY-25@gated-at.bofh.it> <u4xVp-1aY-51@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2017-07-18 12:20 GMT+02:00 Philippe CORNU <philippe.cornu@st.com>:
> Rename the platform driver name from "stm" to "stm32-display"
> for a better readability in /sys/bus/platform/drivers entries.
>
> Note: We keep "stm" as drm_driver.name because it is better
> when using "modetest -M stm ..." (even if recent modetest patch
> avoids using -M).
>
> Signed-off-by: Philippe CORNU <philippe.cornu@st.com>

Reviewed-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>

> ---
>  drivers/gpu/drm/stm/drv.c | 21 +++++++--------------
>  1 file changed, 7 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/stm/drv.c b/drivers/gpu/drm/stm/drv.c
> index 83ab48f..095971f 100644
> --- a/drivers/gpu/drm/stm/drv.c
> +++ b/drivers/gpu/drm/stm/drv.c
> @@ -20,13 +20,6 @@
>
>  #include "ltdc.h"
>
> -#define DRIVER_NAME            "stm"
> -#define DRIVER_DESC            "STMicroelectronics SoC DRM"
> -#define DRIVER_DATE            "20170330"
> -#define DRIVER_MAJOR           1
> -#define DRIVER_MINOR           0
> -#define DRIVER_PATCH_LEVEL     0
> -
>  #define STM_MAX_FB_WIDTH       2048
>  #define STM_MAX_FB_HEIGHT      2048 /* same as width to handle orientation */
>
> @@ -59,12 +52,12 @@ static void drv_lastclose(struct drm_device *ddev)
>         .driver_features = DRIVER_MODESET | DRIVER_GEM | DRIVER_PRIME |
>                            DRIVER_ATOMIC,
>         .lastclose = drv_lastclose,
> -       .name = DRIVER_NAME,
> -       .desc = DRIVER_DESC,
> -       .date = DRIVER_DATE,
> -       .major = DRIVER_MAJOR,
> -       .minor = DRIVER_MINOR,
> -       .patchlevel = DRIVER_PATCH_LEVEL,
> +       .name = "stm",
> +       .desc = "STMicroelectronics SoC DRM",
> +       .date = "20170330",
> +       .major = 1,
> +       .minor = 0,
> +       .patchlevel = 0,
>         .fops = &drv_driver_fops,
>         .dumb_create = drm_gem_cma_dumb_create,
>         .dumb_map_offset = drm_gem_cma_dumb_map_offset,
> @@ -206,7 +199,7 @@ static int stm_drm_platform_remove(struct platform_device *pdev)
>         .probe = stm_drm_platform_probe,
>         .remove = stm_drm_platform_remove,
>         .driver = {
> -               .name = DRIVER_NAME,
> +               .name = "stm32-display",
>                 .of_match_table = drv_dt_ids,
>         },
>  };
> --
> 1.9.1
>

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v1 0/7] drm/stm: Various cleanups Philippe CORNU <philippe.cornu@st.com> - 2017-07-18 12:30 +0200
  [PATCH v1 7/7] drm/stm: dsi: Constify phy ops structure Philippe CORNU <philippe.cornu@st.com> - 2017-07-18 12:30 +0200
    Re: [PATCH v1 7/7] drm/stm: dsi: Constify phy ops structure Benjamin Gaignard <benjamin.gaignard@linaro.org> - 2017-07-20 11:40 +0200
  [PATCH v1 3/7] drm/stm: ltdc: Lindent and minor cleanups Philippe CORNU <philippe.cornu@st.com> - 2017-07-18 12:30 +0200
    Re: [PATCH v1 3/7] drm/stm: ltdc: Lindent and minor cleanups Benjamin Gaignard <benjamin.gaignard@linaro.org> - 2017-07-20 11:30 +0200
  [PATCH v1 1/7] drm/stm: drv: Rename platform driver name Philippe CORNU <philippe.cornu@st.com> - 2017-07-18 12:30 +0200
    Re: [PATCH v1 1/7] drm/stm: drv: Rename platform driver name Benjamin Gaignard <benjamin.gaignard@linaro.org> - 2017-07-20 11:30 +0200
  [PATCH v1 2/7] drm/stm: ltdc: Cleanup signal polarity defines Philippe CORNU <philippe.cornu@st.com> - 2017-07-18 12:30 +0200
    Re: [PATCH v1 2/7] drm/stm: ltdc: Cleanup signal polarity defines Benjamin Gaignard <benjamin.gaignard@linaro.org> - 2017-07-20 11:30 +0200

csiph-web