Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1690011

[PATCH V3 0/5]: spmi: pmic-arb: Fixup patches

From Kiran Gunda <kgunda@codeaurora.org>
Newsgroups linux.kernel
Subject [PATCH V3 0/5]: spmi: pmic-arb: Fixup patches
Date 2017-07-18 12:20 +0200
Message-ID <u4xLH-17C-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


v3:
    * spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup
      replaced "i" with "apid" in pmic_arb_find_apid finction.

    * spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability
      Added Stephen's reviewed-by tag.

v2:
    * spmi: pmic-arb: remove the read/write access checks
      Added Stephen's reviewed-by tag.

    * spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup
      Removed an extra line from the documentation.

    * spmi: pmic-arb: replace the writel_relaxed with __raw_writel
      Added Stephen's reviewed-by tag.

    * spmi: pmic-arb: return the value instead of passing by pointer
      Added Stephen's reviewed-by tag.
      Modified the pmic_arb_offset_* function to return the offset instead
      of passed by a pointer.

    * spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability
      Simplified the qpnpint_irq_set_wake function by using the irq_set_irq_wake
      function instead of using enable_irq_wake/disable_irq_wake.
      
v1:

This patch series is to fix-up the comments given by Stephen Boyd
on the below 11 pathces. These 11 patches were picked up by GregKH
in to his tree and later reviewed by Stephen Boyd. As it is very difficult
to revert the changes from his tree, we decided to let these patches go
in to Greg's tree and provide the fix-up patches later.

Following are the 11 patches picked by Greg:

https://patchwork.kernel.org/patch/9754503/
https://patchwork.kernel.org/patch/9754501/ 
https://patchwork.kernel.org/patch/9754559/
https://patchwork.kernel.org/patch/9754511/
https://patchwork.kernel.org/patch/9754515/
https://patchwork.kernel.org/patch/9754553/
https://patchwork.kernel.org/patch/9754555/
https://patchwork.kernel.org/patch/9754521/
https://patchwork.kernel.org/patch/9754551
https://patchwork.kernel.org/patch/9754525
https://patchwork.kernel.org/patch/9754531/

Also this patch series is dependent on the below patch pushed
by Stephen Boyd. Please take this series after taking this patch
in to the tree.

https://patchwork.kernel.org/patch/9810723/

Kiran Gunda (5):
  spmi: pmic-arb: remove the read/write access checks
  spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup
  spmi: pmic-arb: replace the writel_relaxed with __raw_writel
  spmi: pmic-arb: return the value instead of passing by pointer
  spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup
    capability

 drivers/spmi/spmi-pmic-arb.c | 563 +++++++++++++++++++------------------------
 1 file changed, 250 insertions(+), 313 deletions(-)

-- 
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
 a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[PATCH V3 0/5]: spmi: pmic-arb: Fixup patches Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200
  [PATCH V3 1/5] spmi: pmic-arb: remove the read/write access checks Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200
  [PATCH V3 5/5] spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200
  [PATCH V3 3/5] spmi: pmic-arb: replace the writel_relaxed with __raw_writel Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200
  [PATCH V3 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200
    Re: [PATCH V3 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup Stephen Boyd <sboyd@codeaurora.org> - 2017-07-19 00:50 +0200
      Re: [PATCH V3 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup kgunda@codeaurora.org - 2017-07-20 08:50 +0200
  [PATCH V3 4/5] spmi: pmic-arb: return the value instead of passing by pointer Kiran Gunda <kgunda@codeaurora.org> - 2017-07-18 12:20 +0200

csiph-web