Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1689392

Re: [PATCH] Documentation: dt: chosen property for kaslr-seed

From Rob Herring <robh@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH] Documentation: dt: chosen property for kaslr-seed
Date 2017-07-17 21:40 +0200
Message-ID <u4k26-LB-15@gated-at.bofh.it> (permalink)
References <u3jhL-2Ck-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jul 14, 2017 at 05:38:36PM -0700, Kees Cook wrote:
> Document then /chosen/kaslr-seed property (and its interaction with the

s/then/the/

> EFI_RNG_PROTOCOL API).

"dt-bindings: chosen: ..." for the subject.

> 
> Signed-off-by: Kees Cook <keescook@chromium.org>
> ---
>  Documentation/devicetree/bindings/chosen.txt | 22 ++++++++++++++++++++--
>  1 file changed, 20 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/devicetree/bindings/chosen.txt b/Documentation/devicetree/bindings/chosen.txt
> index dee3f5d9df26..0cdb43b268e5 100644
> --- a/Documentation/devicetree/bindings/chosen.txt
> +++ b/Documentation/devicetree/bindings/chosen.txt
> @@ -5,9 +5,27 @@ The chosen node does not represent a real device, but serves as a place
>  for passing data between firmware and the operating system, like boot
>  arguments. Data in the chosen node does not represent the hardware.
>  
> +The following properties are recognized:
>  
> -stdout-path property
> ---------------------
> +
> +kaslr-seed
> +-----------

Is there some reason we would not feed this to other things needing 
entropy and therefore should have a more generic name?

> +
> +This property is used when booting with CONFIG_RANDOMIZE_BASE to seed
> +the entropy used to randomize the kernel image base address location. It
> +is parsed as a u64 value, e.g.

Why limit the size to 64-bit and why does it matter how the data is 
interpretted? 

> +
> +/ {
> +	chosen {
> +		kaslr-seed = <0xfeedbeef 0xc0def00d>;
> +	};
> +};
> +
> +Note that when booting through EFI when EFI_RNG_PROTOCOL is supported,
> +this value will be overwritten by the EFI stub.

Isn't this always true? The bootloader will overwrite. Just in the EFI 
case, the EFI stub is part of the bootloader from a functional (and not 
packaging) standpoint.

Rob

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] Documentation: dt: chosen property for kaslr-seed Kees Cook <keescook@chromium.org> - 2017-07-15 02:40 +0200
  Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2017-07-15 14:50 +0200
    Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Kees Cook <keescook@chromium.org> - 2017-07-16 04:20 +0200
      Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2017-07-16 18:50 +0200
        Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Mark Rutland <mark.rutland@arm.com> - 2017-07-17 14:00 +0200
          Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Will Deacon <will.deacon@arm.com> - 2017-07-17 15:20 +0200
  Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Rob Herring <robh@kernel.org> - 2017-07-17 21:40 +0200
    Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Kees Cook <keescook@chromium.org> - 2017-07-17 22:00 +0200
      Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2017-07-17 22:30 +0200
        Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Rob Herring <robh@kernel.org> - 2017-07-17 23:10 +0200
          Re: [PATCH] Documentation: dt: chosen property for kaslr-seed Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2017-07-17 23:30 +0200

csiph-web