Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1689179
| From | Miroslav Benes <mbenes@suse.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/2] livepatch: introduce shadow variable API |
| Date | 2017-07-17 17:40 +0200 |
| Message-ID | <u4ghP-6Sd-5@gated-at.bofh.it> (permalink) |
| References | <tXneq-ad-1@gated-at.bofh.it> <tXneq-ad-5@gated-at.bofh.it> <u2WXT-4hp-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, 13 Jul 2017, Josh Poimboeuf wrote: > On Wed, Jun 28, 2017 at 11:37:26AM -0400, Joe Lawrence wrote: > > > +Brief API summary > > +----------------- > > + > > +See the full API usage docbook notes in the livepatch/shadow.c > > +implementation. > > + > > +An in-kernel hashtable references all of the shadow variables. These > > +references are stored/retrieved through a <obj, num> key pair. > > "num" is rather vague, how about "key"? > > (And note, this and some of the other comments also apply to the code as > well) > > > +* The klp_shadow variable data structure encapsulates both tracking > > +meta-data and shadow-data: > > + - meta-data > > + - obj - pointer to original data > > Instead of "original data", how about calling it the "parent object"? > That describes it better to me at least. "Original data" sounds like > some of the data might be replaced. I agree that "original data" does not sound right. However, we use "parent object" for vmlinux or a module in our code. But I don't have a better name and "parent object" sounds good. > > + - num - numerical description of new data > > "numerical description of new data" sounds a little confusing, how about > "unique identifier for new data"? > > I'm also not sure about the phrase "new data". Maybe something like > "new data field" would be more descriptive? Or just "new field"? I > view it kind of like adding a field to a struct. Not a big deal either > way. > > > +void *klp_shadow_attach(void *obj, unsigned long num, void *new_data, > > + size_t new_size, gfp_t gfp_flags); > > It could be just me, but the "new_" prefixes threw me off a little bit. > The new is implied anyway. How about just "data" and "size"? > > And the same comment for the klp_shadow struct. I agree with Josh on all of this. Miroslav
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v2 1/2] livepatch: introduce shadow variable API Josh Poimboeuf <jpoimboe@redhat.com> - 2017-07-14 02:50 +0200 Re: [PATCH v2 1/2] livepatch: introduce shadow variable API Miroslav Benes <mbenes@suse.cz> - 2017-07-17 17:40 +0200
csiph-web