Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1688773

Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization

From Mel Gorman <mgorman@suse.de>
Newsgroups linux.kernel
Subject Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization
Date 2017-07-17 11:00 +0200
Message-ID <u4a2K-2Ji-23@gated-at.bofh.it> (permalink)
References (3 earlier) <u38w2-3Tw-33@gated-at.bofh.it> <u39BL-4A9-15@gated-at.bofh.it> <u47oe-1fK-23@gated-at.bofh.it> <u49gm-2si-15@gated-at.bofh.it> <u49q2-2vC-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Jul 17, 2017 at 10:19:42AM +0200, Michal Hocko wrote:
> On Mon 17-07-17 09:07:23, Mel Gorman wrote:
> > On Mon, Jul 17, 2017 at 08:06:40AM +0200, Michal Hocko wrote:
> > > On Fri 14-07-17 15:18:23, Mel Gorman wrote:
> > > > Fairly sure that's not what you meant.
> > > > 
> > > > 
> > > > >  		pg_data_t *node = NODE_DATA(node_order[i]);
> > > > >  
> > > > > -		zoneref_idx = build_zonelists_node(node, zonelist, zoneref_idx);
> > > > > +		nr_zones = build_zonelists_node(node, zonelist, nr_zones);
> > > > 
> > > > I meant converting build_zonelists_node and passing in &nr_zones and
> > > > returning false when an empty node is encountered. In this context,
> > > > it's also not about zones, it really is nr_zonerefs. Rename nr_zones in
> > > > build_zonelists_node as well.
> > > 
> > > hmm, why don't we rather make it zonerefs based then. Something
> > > like the following?
> > 
> > Works for me.
> 
> Should I fold it to the patch or make it a patch on its own?

I have no strong feelings either way but if it was folded then the
overall naming should be easier to follow (at least for me).

-- 
Mel Gorman
SUSE Labs

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-14 10:10 +0200
  Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Mel Gorman <mgorman@suse.de> - 2017-07-14 12:00 +0200
    Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-14 13:00 +0200
  Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Mel Gorman <mgorman@suse.de> - 2017-07-14 14:50 +0200
    Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-14 15:10 +0200
      Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Mel Gorman <mgorman@suse.de> - 2017-07-14 16:20 +0200
        Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-17 08:10 +0200
          Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Mel Gorman <mgorman@suse.de> - 2017-07-17 10:10 +0200
            Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-17 10:20 +0200
              Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Mel Gorman <mgorman@suse.de> - 2017-07-17 11:00 +0200
                Re: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization Michal Hocko <mhocko@kernel.org> - 2017-07-17 11:20 +0200

csiph-web