Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1690939
| From | Mark yao <mark.yao@rock-chips.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 0/7] drm/rockchip: add all full framework vop support |
| Date | 2017-07-19 05:30 +0200 |
| Message-ID | <u4NQt-2L1-3@gated-at.bofh.it> (permalink) |
| References | <u4Nnt-2lV-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Sorry for sending this mail without thread, my send-patches scripts has a bug:-( , Already fix the script bug. On 2017年07月19日 10:57, Mark Yao wrote: > These patches try to make all current rockchip full framework vop works > on drm, fill missing vop on full framework. > Vop Full framework now has following vops: > IP version chipname > 3.1 rk3288 > 3.2 rk3368 > 3.4 rk3366 > 3.5 rk3399 big > 3.6 rk3399 lit > 3.7 rk3228 > 3.8 rk3328 > > Group the vop register, it would make register definition clearer and > more easily to reuse same group register define for difference vops. > > Tested on rk3399 excavator board with kernel 4.13-rc1. > > And other chips tested on rockchip kernel 4.4: > https://github.com/rockchip-linux/kernel/tree/release-4.4/drivers/gpu/drm/rockchip > > Changes in v4: > - rebase to newest torvalds kernel, fix merge conflict > > Changes in v3: > - group vop register instead using VOP_REG_VER mechanism > - move write_relaxed flags to vop registers > - Explain more on patch commit message > - fix rk3328 overlay abnormal > > Changes in v2: > - rename rk322x to rk3228(Heiko Stübner) > - correct some vop registers define > > Mark Yao (7): > drm/rockchip: vop: initialize registers directly > drm/rockchip: vop: move write_relaxed flags to vop register > drm/rockchip: vop: move line_flag_num to interrupt registers > drm/rockchip: vop: group vop registers > drm/rockchip: vop: add a series of vop support > dt-bindings: display: fill Documents for series of vop > drm/rockchip: vop: rk3328: fix overlay abnormal > > .../bindings/display/rockchip/rockchip-vop.txt | 4 + > drivers/gpu/drm/rockchip/rockchip_drm_vop.c | 109 ++- > drivers/gpu/drm/rockchip/rockchip_drm_vop.h | 81 +- > drivers/gpu/drm/rockchip/rockchip_vop_reg.c | 374 ++++++--- > drivers/gpu/drm/rockchip/rockchip_vop_reg.h | 905 ++++++++++++++++----- > 5 files changed, 1074 insertions(+), 399 deletions(-) > -- Mark Yao
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v4 0/7] drm/rockchip: add all full framework vop support Mark Yao <mark.yao@rock-chips.com> - 2017-07-19 05:00 +0200 Re: [PATCH v4 0/7] drm/rockchip: add all full framework vop support Mark yao <mark.yao@rock-chips.com> - 2017-07-19 05:30 +0200
csiph-web