Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1684772
| Path | csiph.com!news.redatomik.org!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Frank Rowand <frowand.list@gmail.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/3] of: overlay: add overlay unittest data for node names and symbols |
| Date | Tue, 11 Jul 2017 07:00:02 +0200 |
| Message-ID | <u1Vrc-68T-13@gated-at.bofh.it> (permalink) |
| References | <u1Mee-y8-13@gated-at.bofh.it> <u1Mee-y8-15@gated-at.bofh.it> <u1TfH-4Tg-1@gated-at.bofh.it> |
| X-Original-To | Rob Herring <robh+dt@kernel.org> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=subject:to:references:cc:from:message-id:date:user-agent :mime-version:in-reply-to:content-transfer-encoding; bh=8YZRSbElzAfq+zuEoKpH4TerJ+S/S1jg55nxJC74UhU=; b=XGPLSW3kj1H17UCXHxNikLy91osuT8Im5YOszuMRXxbVz5huk822R+xpc3MVtXpi0z 8qNSvgfOZVoVpVvGeqZQ/YmEHnzLfZ/p7JCaXEZSKVSxrH2F9SVDY1X4JFwT5fRz8aMq TJR8L0MpaUhyz1gTl4S04uU1HhS3Mqdda39rAtMvdQQ9FiL2+gY5e3tCVsBInsPVLjYk 6CGOY9SEk50x2L09eMbG73YofxTDtqBgk3M6rKqeYeFlfNG2rp3//n36ROMuqYJRMbBt MkXTKgZF/WKGZB7iCOLdGfotle7Ge8WY/mNe/vULQWJppO48xzL0jGUfeDLBiK7AhKlG C2sg== |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:subject:to:references:cc:from:message-id:date :user-agent:mime-version:in-reply-to:content-transfer-encoding; bh=8YZRSbElzAfq+zuEoKpH4TerJ+S/S1jg55nxJC74UhU=; b=Fr9Fs58EzW14p+vC5xJK22gyp3BXLgIZEhP+YXjrKXKbnAL2fhNwXykmdafENZnuDL 4lHfqGTaQfyMBwql62pBxy7qJd12VCvze7+Urgq08FhMz4KDGxFdKjZP7G/EEscK0k0C dyFwyJDyCj2obIQv3juXCf+ANhtFRz10uVwRaO/JuQsMljrbfGrZU1C1ZyiPBtw8C4/V RA6369Omoue5qXi2dwUJjg9iU5RiHUKFQp0FEut/dWYhbaGBkYnR5XGqyPtXy2jliBBc dFp3+gvyKFZHFu8Eo5eP2TuQ898X0cESzklRnLPRs78s97nFMkDG6NdEHgpmK+CxMf5x aZrw== |
| X-Gm-Message-State | AIVw112XbrcvKvoZh49L6evq8f3hunp/FMeTzaHqxZ7KrFO0dEI24GKA mrYwFStm+2aNVA== |
| X-Received | by 10.84.173.129 with SMTP id p1mr21766356plb.143.1499748754499; Mon, 10 Jul 2017 21:52:34 -0700 (PDT) |
| User-Agent | Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.4.0 |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=utf-8 |
| Content-Transfer-Encoding | 7bit |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 93 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Pantelis Antoniou <pantelis.antoniou@konsulko.com>, Pantelis Antoniou <panto@antoniou-consulting.com>, "devicetree@vger.kernel.org" <devicetree@vger.kernel.org>, "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org> |
| X-Original-Date | Mon, 10 Jul 2017 21:52:25 -0700 |
| X-Original-Message-ID | <59645989.5050502@gmail.com> |
| X-Original-References | <1499713523-19184-1-git-send-email-frowand.list@gmail.com> <1499713523-19184-2-git-send-email-frowand.list@gmail.com> <CAL_Jsq+dq0nngUePGvuyELmtexJyUMaTpnN1D8uEBbSPjphVyQ@mail.gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1684772 |
Show key headers only | View raw
On 07/10/17 19:31, Rob Herring wrote:
> On Mon, Jul 10, 2017 at 2:05 PM, <frowand.list@gmail.com> wrote:
>> From: Frank Rowand <frank.rowand@sony.com>
>>
>> Add nodes and properties to overlay_base and overlay dts files to
>> test for
>> - incorrect existing node name detection when overlay node name
>> has a unit-address
>> - adding overlay __symbols__ properties to live tree when an
>> overlay is added to the live tree
>>
>> Expected result from patch 2/3 is overlay will update the nodes and
>> properties for /testcase-data-2/fairway-1/ride@100/
>>
>> Before patch 2/3 is applied:
>
> This is good information, but what is patch 2/3 is less clear when
> this is committed.
Yes, but that is the best way I've figured out to convey the information.
I'm expecting the three patches to be three consecutive commits in the
history. I'd love to have a way to specify what the commit id of
patch 3 will be in the patch 1 commit message. Given the way that
I think git works, I don't think there is any way the git wizards
will be able to add that feature. Maybe it would be clearer to
reference the short description of patch 2 and patch 3 instead.
> And 1 and 2 are probably stable material? I'd just
> note in this patch what the failures are and show before and after
> results in the patch that changes them.
I consider overlays to be a not yet functional feature, that
still needs a some more code before being usable. In that case,
I don't think it is worth marking the patches for stable.
>> Console error message near end of unittest:
>> OF: Duplicate name in fairway-1, renamed to "ride@100#1"
>>
>> $ cd /proc/device-tree/testcase-data-2/fairway-1/
>> $ # extra node: ride@100#1
>> $ ls
>> #address-cells linux,phandle phandle ride@200
>> #size-cells name ride@100 status
>> compatible orientation ride@100#1
>> $ cd /proc/device-tree/testcase-data-2/fairway-1/ride@100/
>> $ ls track@3/incline_up
>> ls: track@3/incline_up: No such file or directory
>> $ ls track@4/incline_up
>> ls: track@4/incline_up: No such file or directory
>
> [...]
>
>> diff --git a/drivers/of/unittest-data/Makefile b/drivers/of/unittest-data/Makefile
>> index 6e00a9c69e58..dae2fe23cd2e 100644
>> --- a/drivers/of/unittest-data/Makefile
>> +++ b/drivers/of/unittest-data/Makefile
>> @@ -1,11 +1,13 @@
>> obj-y += testcases.dtb.o
>> obj-y += overlay.dtb.o
>> obj-y += overlay_bad_phandle.dtb.o
>> +obj-y += overlay_bad_symbol.dtb.o
>> obj-y += overlay_base.dtb.o
>
> There's no reason for these all to be 1 per line.
OK. Do you prefer something like:
obj-y += testcases.dtb.o overlay.dtb.o overlay_bad_phandle.dtb.o \
overlay_bad_symbol.dtb.o overlay_base.dtb.o
My preference is to keep the objects in alphabetic order. That might
argue for something easier to read and update, like:
obj-y += testcases.dtb.o \
overlay.dtb.o \
overlay_bad_phandle.dtb.o \
overlay_bad_symbol.dtb.o \
overlay_base.dtb.o
> Also, should the
> overlay dtb's be conditioned on CONFIG_OF_OVERLAY (or whatever we call
> it)?
I think so. I'll verify that it doesn't break anything (and if so fix
the breakage).
>
> But this is fine. That can all be a followup patch.
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/3] of: overlay: load overlay symbols into live device tree frowand.list@gmail.com - 2017-07-10 21:10 +0200
[PATCH v2 2/3] of: overlay: correctly apply overlay node with unit-address frowand.list@gmail.com - 2017-07-10 21:10 +0200
[PATCH v2 1/3] of: overlay: add overlay unittest data for node names and symbols frowand.list@gmail.com - 2017-07-10 21:10 +0200
Re: [PATCH v2 1/3] of: overlay: add overlay unittest data for node names and symbols Rob Herring <robh+dt@kernel.org> - 2017-07-11 04:40 +0200
Re: [PATCH v2 1/3] of: overlay: add overlay unittest data for node names and symbols Frank Rowand <frowand.list@gmail.com> - 2017-07-11 07:00 +0200
Re: [PATCH v2 1/3] of: overlay: add overlay unittest data for node names and symbols Rob Herring <robh+dt@kernel.org> - 2017-07-11 21:40 +0200
[PATCH v2 3/3] of: overlay: add overlay symbols to live device tree frowand.list@gmail.com - 2017-07-10 21:10 +0200
csiph-web