Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1684715

Re: [PATCH V2 5/5] spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability

From Stephen Boyd <sboyd@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH V2 5/5] spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability
Date 2017-07-11 03:30 +0200
Message-ID <u1S9X-486-3@gated-at.bofh.it> (permalink)
References <u1Giu-56Z-7@gated-at.bofh.it> <u1Giv-56Z-55@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 07/10, Kiran Gunda wrote:
> Currently the driver sets the pmic arbiter core interrupt as wakeup capable
> irrespective of the child irqs which causes the system to wakeup
> unnecessarily. To fix this, set the core interrupt as wakeup capable
> only if any of the child irqs request for it. Do this by marking it as
> wakeup capable in the irq_set_wake callback.
> 
> Signed-off-by: Kiran Gunda <kgunda@codeaurora.org>
> ---

Reviewed-by: Stephen Boyd <sboyd@codeaurora.org>

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH V2 0/5]: spmi: pmic-arb: Fixup patches Kiran Gunda <kgunda@codeaurora.org> - 2017-07-10 14:50 +0200
  [PATCH V2 5/5] spmi: pmic-arb: use irq_chip callback to set spmi irq wakeup capability Kiran Gunda <kgunda@codeaurora.org> - 2017-07-10 14:50 +0200
    Re: [PATCH V2 5/5] spmi: pmic-arb: use irq_chip callback to set spmi  irq wakeup capability Stephen Boyd <sboyd@codeaurora.org> - 2017-07-11 03:30 +0200
  [PATCH V2 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and other code cleanup Kiran Gunda <kgunda@codeaurora.org> - 2017-07-10 14:50 +0200
    Re: [PATCH V2 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup Stephen Boyd <sboyd@codeaurora.org> - 2017-07-14 20:30 +0200
      Re: [PATCH V2 2/5] spmi: pmic-arb: rename pa_xx to pmic_arb_xx and  other code cleanup kgunda@codeaurora.org - 2017-07-18 07:00 +0200

csiph-web