Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1682379
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] jprobes: Ensure that the probepoint is at function entry |
| Date | 2017-07-06 14:20 +0200 |
| Message-ID | <u0dVf-4cO-7@gated-at.bofh.it> (permalink) |
| References | <tXJ5h-qk-25@gated-at.bofh.it> <tZQ2B-56s-7@gated-at.bofh.it> <u0bTt-2TC-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Masami Hiramatsu <mhiramat@kernel.org> wrote: > > Also, 'function_offset_within_entry' is way too long a name, and it's also a > > minomer I think. The purpose of this function is to enforce that the relative > > 'offset' of a new probe is at the standard function entry offset: i.e. 0 on most > > architectures, and some ABI dependent constant on PowerPC, right? > > > > That's not at all clear from that name, plus it's a global namespace symbol, yet > > has no 'kprobes' prefix. So it should be named something like > > 'kprobe_offset_valid()' or such, with an arch_kprobe_offset_valid() counterpart. > > Hmm, I would rather like kprobe_within_entry(), since offset != 0 is > actually valid for normal kprobe, that is kretprobe and jprobe limitation. But what entry? That it's within a range or that offset is always 0 is really an implementational detail: depending on what type of kprobe it is, it is either validly within the confines of the specified function symbol or not. What _really_ matters to callers is whether it's a valid kprobe to be inserted into that function, right? I.e. the long name came from over-specifying what is done by the function - while simplifying makes it actually more meaningful to read. Thanks, Ingo
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry Ingo Molnar <mingo@kernel.org> - 2017-07-05 12:50 +0200
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry Masami Hiramatsu <mhiramat@kernel.org> - 2017-07-06 12:10 +0200
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry Ingo Molnar <mingo@kernel.org> - 2017-07-06 14:20 +0200
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry Masami Hiramatsu <mhiramat@kernel.org> - 2017-07-07 03:10 +0200
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry Ingo Molnar <mingo@kernel.org> - 2017-07-07 12:50 +0200
Re: [PATCH] jprobes: Ensure that the probepoint is at function entry "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-07-07 13:30 +0200
csiph-web