Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1683592
| From | Thomas Gleixner <tglx@linutronix.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions |
| Date | 2017-07-08 14:10 +0200 |
| Message-ID | <u0WIG-22T-13@gated-at.bofh.it> (permalink) |
| References | <u0H6W-8rJ-13@gated-at.bofh.it> <u0H6X-8rJ-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, 7 Jul 2017, Doug Berger wrote:
> The irq_gc_mask_disable_reg_and_ack() function name implies that it
> provides the combined functions of irq_gc_mask_disable_reg() and
> irq_gc_ack(). However, the implementation does not actually do
> that since it writes the mask instead of the disable register. It
> also does not maintain the mask cache which makes it inappropriate
> to use with other masking functions.
>
> In addition, commit 659fb32d1b67 ("genirq: replace irq_gc_ack() with
> {set,clr}_bit variants (fwd)") effectively renamed irq_gc_ack() to
> irq_gc_set_bit() so this function probably should have also been
> renamed at that time.
>
> Since this generic chip code provides three mask functions and two
> ack functions, this commit provides generic implementations for all
> six combinations of the mask and ack functions suitable for use
> with the irq_mask_ack member of the struct irq_chip.
We have exactly one user of irq_gc_mask_disable_reg_and_ack() and that
needs exactly on function as replacement. Why do we need 6 variants of
that right now?
Thanks,
tglx
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Doug Berger <opendmb@gmail.com> - 2017-07-07 21:30 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Thomas Gleixner <tglx@linutronix.de> - 2017-07-08 14:10 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Doug Berger <opendmb@gmail.com> - 2017-07-10 19:40 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Doug Berger <opendmb@gmail.com> - 2017-07-17 19:30 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Thomas Gleixner <tglx@linutronix.de> - 2017-07-17 23:00 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Doug Berger <opendmb@gmail.com> - 2017-07-12 21:30 +0200
Re: [PATCH 1/6] genirq: generic chip: add generic irq_mask_ack functions Måns Rullgård <mans@mansr.com> - 2017-07-12 23:00 +0200
csiph-web