Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1629669
| Path | csiph.com!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Arnd Bergmann <arnd@arndb.de> |
| Newsgroups | linux.kernel |
| Subject | Re: [alsa-devel] [PATCH 1/2] ASoC: codec: wm9860: avoid maybe-uninitialized warning |
| Date | Mon, 24 Apr 2017 17:30:01 +0200 |
| Message-ID | <tzO65-eo-13@gated-at.bofh.it> (permalink) |
| References | <tyLtF-Ix-41@gated-at.bofh.it> <tyLtF-Ix-43@gated-at.bofh.it> <tyLtF-Ix-39@gated-at.bofh.it> <tzM4i-7tv-21@gated-at.bofh.it> |
| X-Original-To | Daniel Baluta <daniel.baluta@gmail.com> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:cc:content-transfer-encoding; bh=tA7I7uKyTqm75gdS6tjOAWjDUKAvXb+rwrtVHXGmvFM=; b=BMhuk+6WtYLGLX/grEhpD7sdI40GXwLflUXHuDGgs/Ec/uGUPb/6rHM2zk5R7DTYZg 8IS6SjKetuyx43qyJJJdtfKEkba+Yp67mlmWMHpbehe1O/0rdW2/QG7VT3sJ1fRbpWje tp3UJE2yT/j6MB4xUOn8iEhpXxDlshkbUnbv4I9fklBRb2mjp/Jl6NChIyAWaXcOkLza Ozo4NXsBwQHsBgvJ5qDUub197JBMHLk2rgmIAsPJyMQfC37r3ogpr9l1n36kYkM6ucW4 2XDrcGMcg/xs0BpGLzdmdqEqCorHJOIhy+x3PXbzJJxZaA3GBwLXnOQkV7Njz0MpKdRz CP5g== |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:sender:in-reply-to:references:from :date:message-id:subject:to:cc:content-transfer-encoding; bh=tA7I7uKyTqm75gdS6tjOAWjDUKAvXb+rwrtVHXGmvFM=; b=UjYPuIAhc6qOVyakXcxIBoUPmxtVTm99EC5bnCsCJg3zOaY0KniztHEjWK4TxvzagZ xjP2cokITRAN3tCB6iHUwiW2jYcx/ZHncpglpOhXMAgvXWC5rhLPdlDfTLAEE/s4FQXS OE9A7rVZcmhigMs09bILdrME0DX+GqOjmvrvYvfNrDIaHtVp1IpVyeMuny3+lwkoXo8Q Kkumz6CCR2IsSRAFaUeXaJn79Ahdkx27kNhhRni9y7PUcUeFUVJevjpGLPrkCdTAt3Rn w1Wykkt60Zeds5jUvq73JCTd8Ic++8wiTgXkAMigyfUKmClAa+4EaigHe/DQUg+RiXrJ neCQ== |
| X-Gm-Message-State | AN3rC/5fZPYkFi238kN3WGx8+x5lkkIDruEaxURO0K8t4vR+aCrBIkL2 6pgHQL2xcncly2mo/FrVet09KGZ4/w== |
| X-Received | by 10.202.217.85 with SMTP id q82mr13570287oig.92.1493047645716; Mon, 24 Apr 2017 08:27:25 -0700 (PDT) |
| MIME-Version | 1.0 |
| X-Google-Sender-Auth | rlKDz2glv_rNAZUNCSRHrTp1tQ8 |
| Content-Type | text/plain; charset=UTF-8 |
| Content-Transfer-Encoding | quoted-printable |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 172 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Daniel Baluta <daniel.baluta@nxp.com>, alsa-devel@alsa-project.org, Linux Kernel Mailing List <linux-kernel@vger.kernel.org>, patches@opensource.wolfsonmicro.com, Takashi Iwai <tiwai@suse.com>, Liam Girdwood <lgirdwood@gmail.com>, Mark Brown <broonie@kernel.org>, Charles Keepax <ckeepax@opensource.wolfsonmicro.com> |
| X-Original-Date | Mon, 24 Apr 2017 17:27:25 +0200 |
| X-Original-Message-ID | <CAK8P3a20+0sa0cZKoMu0SoqYtVMzJZumGzDpwEaSMJw_zbckfg@mail.gmail.com> |
| X-Original-References | <1492780055-4892-1-git-send-email-daniel.baluta@nxp.com> <1492780055-4892-2-git-send-email-daniel.baluta@nxp.com> <CAK8P3a3GD-S1-szw5tw1R8eSS0AXL_hwJm+d-KF4XuKtYGf-VQ@mail.gmail.com> <CAEnQRZCHgahg=Vem_rrbZWzVM7KJi1B_Q3NAKr_sxXA5K0-AEw@mail.gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1629669 |
Show key headers only | View raw
On Mon, Apr 24, 2017 at 3:15 PM, Daniel Baluta <daniel.baluta@gmail.com> wrote:
> On Fri, Apr 21, 2017 at 5:46 PM, Arnd Bergmann <arnd@arndb.de> wrote:
>> On Fri, Apr 21, 2017 at 3:07 PM, Daniel Baluta <daniel.baluta@nxp.com> wrote:
>>> The new PLL configuration code triggers a harmless warning:
>>>
>>> sound/soc/codecs/wm8960.c: In function 'wm8960_configure_clocking':
>>> sound/soc/codecs/wm8960.c:735:3: error: 'best_freq_out' may be used
>>> uninitialized in this function [-Werror=maybe-uninitialized]
>>> wm8960_set_pll(codec, freq_in, best_freq_out);
>>> ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>>> sound/soc/codecs/wm8960.c:699:12: note: 'best_freq_out' was declared
>>> here
>>>
>>> Fixes: 84fdc00d519f ("ASoC: codec: wm9860: Refactor PLL out freq search")
>>> Fixes: 303e8954af8d ("ASoC: codec: wm8960: Stop when a matching PLL freq is found")
>>> Suggested-by: Arnd Bergmann <arnd@arndb.de>
>>> Signed-off-by: Daniel Baluta <daniel.baluta@nxp.com>
>>> ---
>>> Arnd,
>>>
>>> I agree that your code was more both humans and gcc anyhow
>>> for consistency with wm8960_configure_sysclk function I preferred
>>> to keep the "if(..) break" statements.
>>
>> How about changing both functions the same way then?
>
> I've tried but I couldn't find any solution. For clarity here is how
> the code actually looks like.
>
> The git diff is a little bit misleading. Here is how wm8960_configure_pll code
> looks like:
>
> https://pastebin.com/naGdVNQz
>
> static
> int wm8960_configure_pll(struct snd_soc_codec *codec, int freq_in,
> » » » int *sysclk_idx, int *dac_idx, int *bclk_idx)
> {
> » struct wm8960_priv *wm8960 = snd_soc_codec_get_drvdata(codec);
> » int sysclk, bclk, lrclk, freq_out;
> » int diff, closest, best_freq_out;
> » int i, j, k;
>
> » bclk = wm8960->bclk;
> » lrclk = wm8960->lrclk;
> » closest = freq_in;
>
> » best_freq_out = -EINVAL;
> » *sysclk_idx = *dac_idx = *bclk_idx = -1;
>
> » for (i = 0; i < ARRAY_SIZE(sysclk_divs); ++i) {
> » » if (sysclk_divs[i] == -1)
> » » » continue;
> » » for (j = 0; j < ARRAY_SIZE(dac_divs); ++j) {
> » » » sysclk = lrclk * dac_divs[j];
> » » » freq_out = sysclk * sysclk_divs[i];
>
> » » » for (k = 0; k < ARRAY_SIZE(bclk_divs); ++k) {
> » » » » if (!is_pll_freq_available(freq_in, freq_out))
> » » » » » continue;
>
> » » » » diff = sysclk - bclk * bclk_divs[k] / 10;
> » » » » if (diff == 0) {
> » » » » » *sysclk_idx = i;
> » » » » » *dac_idx = j;
> » » » » » *bclk_idx = k;
> » » » » » best_freq_out = freq_out;
> » » » » » break;
> » » » » }
> » » » » if (diff > 0 && closest > diff) {
> » » » » » *sysclk_idx = i;
> » » » » » *dac_idx = j;
> » » » » » *bclk_idx = k;
> » » » » » closest = diff;
> » » » » » best_freq_out = freq_out;
> » » » » }
> » » » }
> » » » if (k != ARRAY_SIZE(bclk_divs))
> » » » » break;
> » » }
> » » if (j != ARRAY_SIZE(dac_divs))
> » » » break;
> » }
>
> » return best_freq_out;
> }
>
> In my opinion this is a compiler false positive. Any clue on how to rework this
> would be welcomed :). I couldn't find any decent solution.
Actually I think in this case the compiler is supposed to warn if
best_freq_out is not initialized, as we would never set it
in case is_pll_freq_available() returns false for all inputs or
sysclk_divs[] is -1 for all fields.
I'd leave the initialization then, and only replace the breaks
with a goto (not tested):
> » for (i = 0; i < ARRAY_SIZE(sysclk_divs); ++i) {
> » » if (sysclk_divs[i] == -1)
> » » » continue;
> » » for (j = 0; j < ARRAY_SIZE(dac_divs); ++j) {
> » » » sysclk = lrclk * dac_divs[j];
> » » » freq_out = sysclk * sysclk_divs[i];
>
> » » » for (k = 0; k < ARRAY_SIZE(bclk_divs); ++k) {
> » » » » if (!is_pll_freq_available(freq_in, freq_out))
> » » » » » continue;
>
> » » » » diff = sysclk - bclk * bclk_divs[k] / 10;
> » » » » if (diff == 0) {
> » » » » » *sysclk_idx = i;
> » » » » » *dac_idx = j;
> » » » » » *bclk_idx = k;
> » » » » » best_freq_out = freq_out;
> » » » » » goto out;
> » » » » }
> » » » » if (diff > 0 && closest > diff) {
> » » » » » *sysclk_idx = i;
> » » » » » *dac_idx = j;
> » » » » » *bclk_idx = k;
> » » » » » closest = diff;
> » » » » » best_freq_out = freq_out;
> » » » » }
> » » » }
> » » }
> » }
>out:
> » return best_freq_out;
> }
Arnd
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH 1/2] ASoC: codec: wm9860: avoid maybe-uninitialized warning Arnd Bergmann <arnd@arndb.de> - 2017-04-21 20:30 +0200
Re: [alsa-devel] [PATCH 1/2] ASoC: codec: wm9860: avoid maybe-uninitialized warning Daniel Baluta <daniel.baluta@gmail.com> - 2017-04-24 15:20 +0200
Re: [alsa-devel] [PATCH 1/2] ASoC: codec: wm9860: avoid maybe-uninitialized warning Arnd Bergmann <arnd@arndb.de> - 2017-04-24 17:30 +0200
Re: [alsa-devel] [PATCH 1/2] ASoC: codec: wm9860: avoid maybe-uninitialized warning Daniel Baluta <daniel.baluta@gmail.com> - 2017-04-25 12:20 +0200
csiph-web