Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1627800

Re: [PATCH 00/29] IB/mlx: Fine-tuning for several function implementations

From Doug Ledford <dledford@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH 00/29] IB/mlx: Fine-tuning for several function implementations
Date 2017-04-20 22:40 +0200
Message-ID <tyr1U-565-17@gated-at.bofh.it> (permalink)
References <tck77-6Ef-3@gated-at.bofh.it>
Organization Red Hat, Inc.

Show all headers | View raw


On Sat, 2017-02-18 at 21:45 +0100, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Sat, 18 Feb 2017 21:34:32 +0100
> 
> Several update suggestions were taken into account
> from static source code analysis.

I've dropped this entire series.  If you want me to consider it, you
need to respin it with the following changes:

1) Put all similar corrections in a single patch.  If you are replacing
a sizeof() usage with a safer sizeof() usage, then I don't want one
patch per replacement, I want one patch for all replacements.

2) Use reasonable git commit messages.  "Improve another" is never a
reasonable commit message because it implicitly refereces another git
commit message.  Unless this is a fix for a previous commit, all commit
messages should be standalone.

3) Keep your git commit message subject lines within the recommended
size.  You have many that are too long.  As trivial as all of these
changes are, I'm not going to go fixup 29 commit messages to take them.

4) Make sure to preserve the reviewed-by tags on the resubmission.

> Markus Elfring (29):
>   Use kcalloc() in mlx4_ib_alloc_pv_bufs()
>   Improve another size determination in mlx4_ib_alloc_pv_bufs()
>   Improve another size determination in mlx4_ib_alloc_demux_ctx()
>   Improve another size determination in alloc_pv_object()
>   Fix a typo in a comment line
>   Delete three unnecessary return statements
>   Split a condition check in handle_slaves_guid_change()
>   Delete an unnecessary check before the function call "kfree" in
> free_pv_object()
>   Move an assignment out of a check in forward_trap()
>   Enclose 15 expressions for the sizeof operator by parentheses
>   Use kmalloc_array() in three functions
>   Enclose 17 expressions for the sizeof operator by parentheses
>   Split a condition check in five functions
>   Delete an unnecessary variable in __mlx4_ib_query_gid()
>   Delete an unnecessary return statement in do_slave_init()
>   Improve another size determination in do_slave_init()
>   Improve another size determination in mlx4_ib_add()
>   Delete an unnecessary variable initialisation in mlx4_ib_add()
>   Delete an unnecessary variable assignment in mlx4_ib_add()
>   Delete an error message for a failed memory allocation in
> mlx4_ib_add()
>   Delete unnecessary braces in mlx4_ib_add()
>   Use kmalloc_array() in alloc_proxy_bufs()
>   Improve size determinations in create_qp_common()
>   Delete unwanted spaces behind usages of the sizeof operator
>   Add spaces for better code readability
>   Enclose 14 expressions for the sizeof operator by parentheses
>   Use kmalloc_array() in create_kernel_qp()
>   Less function calls in create_kernel_qp() after error detection
>   Use kmalloc_array() in create_srq_kernel()
> 
>  drivers/infiniband/hw/mlx4/mad.c  |  72 ++++++++--------
>  drivers/infiniband/hw/mlx4/main.c | 164 ++++++++++++++++++++------
> ----------
>  drivers/infiniband/hw/mlx4/qp.c   | 173 +++++++++++++++++++---------
> ----------
>  drivers/infiniband/hw/mlx5/qp.c   |  66 ++++++++++-----
>  drivers/infiniband/hw/mlx5/srq.c  |   5 +-
>  5 files changed, 261 insertions(+), 219 deletions(-)
> 
-- 
Doug Ledford <dledford@redhat.com>
    GPG KeyID: B826A3330E572FDD
   
Key fingerprint = AE6B 1BDA 122B 23B4 265B  1274 B826 A333 0E57 2FDD

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [PATCH 00/29] IB/mlx: Fine-tuning for several function  implementations Doug Ledford <dledford@redhat.com> - 2017-04-20 22:40 +0200
  Re: [PATCH 00/29] IB/mlx: Fine-tuning for several function  implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-20 23:10 +0200
    Re: [PATCH 00/29] IB/mlx: Fine-tuning for several function  implementations Doug Ledford <dledford@redhat.com> - 2017-04-21 04:30 +0200
  [PATCH v2 02/17] IB/mlx: Use kmalloc_array() in six functions SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:30 +0200
  [PATCH v2 00/17] IB/mlx: Fine-tuning for several function  implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:30 +0200
    [PATCH v2 01/17] IB/mlx4: Use kcalloc() in mlx4_ib_alloc_pv_bufs() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:30 +0200
    [PATCH v2 07/17] IB/mlx4: Move an assignment out of a check in  forward_trap() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    [PATCH v2 05/17] IB/mlx4: Delete four unnecessary return statements SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    [PATCH v2 08/17] IB/mlx4: Enclose 46 expressions for sizeof by  parentheses SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    [PATCH v2 04/17] IB/mlx4: Fix a typo in a comment line SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    [PATCH v2 06/17] IB/mlx4: Delete an unnecessary check before kfree()  in free_pv_object() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    [PATCH v2 03/17] IB/mlx4: Improve size determinations in six  functions SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:40 +0200
    Re: [PATCH v2 00/17] IB/mlx: Fine-tuning for several function  implementations Bart Van Assche <Bart.VanAssche@sandisk.com> - 2017-04-21 20:40 +0200
      Re: IB/mlx: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 21:30 +0200
        Re: IB/mlx: Fine-tuning for several function implementations Bart Van Assche <Bart.VanAssche@sandisk.com> - 2017-04-21 22:00 +0200
    [PATCH v2 12/17] IB/mlx4: Delete an unnecessary variable assignment  in mlx4_ib_add() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:50 +0200
    [PATCH v2 13/17] IB/mlx4: Delete an error message for a failed memory  allocation in mlx4_ib_add() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:50 +0200
    [PATCH v2 11/17] IB/mlx4: Delete an unnecessary variable  initialisation in mlx4_ib_add() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:50 +0200
    [PATCH v2 10/17] IB/mlx4: Delete an unnecessary variable in  __mlx4_ib_query_gid() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:50 +0200
    [PATCH v2 09/17] IB/mlx4: Split a condition check in six functions SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 20:50 +0200
    [PATCH v2 17/17] IB/mlx5: Less function calls in create_kernel_qp()  after error detection SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 21:00 +0200
    [PATCH v2 16/17] IB/mlx4: Add spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 21:00 +0200
      Re: [PATCH v2 16/17] IB/mlx4: Add spaces for better code readability Joe Perches <joe@perches.com> - 2017-04-21 21:30 +0200
    [PATCH v2 14/17] IB/mlx4: Delete unnecessary braces in mlx4_ib_add() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 21:00 +0200
    [PATCH v2 15/17] IB/mlx4: Delete unwanted spaces behind usages of the  sizeof operator SF Markus Elfring <elfring@users.sourceforge.net> - 2017-04-21 21:00 +0200

csiph-web