Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1627221

Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning

From Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
Newsgroups linux.kernel
Subject Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning
Date 2017-04-20 11:10 +0200
Message-ID <tygga-73a-13@gated-at.bofh.it> (permalink)
References <ty1h9-68e-47@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Apr 19, 2017 at 07:04:20PM +0200, Arnd Bergmann wrote:
> The new PLL configuration code triggers a harmless warning:
> 
> sound/soc/codecs/wm8960.c: In function 'wm8960_configure_clocking':
> sound/soc/codecs/wm8960.c:735:3: error: 'best_freq_out' may be used uninitialized in this function [-Werror=maybe-uninitialized]
>    wm8960_set_pll(codec, freq_in, best_freq_out);
>    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> sound/soc/codecs/wm8960.c:699:12: note: 'best_freq_out' was declared here
> 
> I think the warning was introduced by Daniel's bugfix. I've come up
> with a way to simplify the code in a way that is more readable to
> both humans and to gcc, which gets us rid of the warning.
> 
> Fixes: 84fdc00d519f ("ASoC: codec: wm9860: Refactor PLL out freq search")
> Fixes: 303e8954af8d ("ASoC: codec: wm8960: Stop when a matching PLL freq is found")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
> ---

Acked-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>

Thanks,
Charles

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Arnd Bergmann <arnd@arndb.de> - 2017-04-19 19:10 +0200
  Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Daniel Baluta <daniel.baluta@gmail.com> - 2017-04-20 08:50 +0200
    Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Arnd Bergmann <arnd@arndb.de> - 2017-04-20 09:50 +0200
      Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Daniel Baluta <daniel.baluta@gmail.com> - 2017-04-20 10:30 +0200
      Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Mark Brown <broonie@kernel.org> - 2017-04-20 21:50 +0200
  Re: [PATCH] ASoC: codec: wm9860: avoid maybe-uninitialized warning Charles Keepax <ckeepax@opensource.wolfsonmicro.com> - 2017-04-20 11:10 +0200

csiph-web