Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1628768

Re: [PATCH] xprtrdma: use offset_in_page() macro

From Chuck Lever <chuck.lever@oracle.com>
Newsgroups linux.kernel
Subject Re: [PATCH] xprtrdma: use offset_in_page() macro
Date 2017-04-22 05:40 +0200
Message-ID <tyU3T-61v-23@gated-at.bofh.it> (permalink)
References <tyS26-4Ml-7@gated-at.bofh.it> <tyS27-4Ml-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


> On Apr 21, 2017, at 9:21 PM, Geliang Tang <geliangtang@gmail.com> wrote:
> 
> Use offset_in_page() macro instead of open-coding.
> 
> Signed-off-by: Geliang Tang <geliangtang@gmail.com>
> ---
> net/sunrpc/xprtrdma/rpc_rdma.c        | 4 ++--
> net/sunrpc/xprtrdma/svc_rdma_sendto.c | 3 +--
> 2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/net/sunrpc/xprtrdma/rpc_rdma.c b/net/sunrpc/xprtrdma/rpc_rdma.c
> index a044be2..429beea 100644
> --- a/net/sunrpc/xprtrdma/rpc_rdma.c
> +++ b/net/sunrpc/xprtrdma/rpc_rdma.c
> @@ -540,7 +540,7 @@ rpcrdma_prepare_msg_sges(struct rpcrdma_ia *ia, struct rpcrdma_req *req,
> 			goto out;
> 
> 		page = virt_to_page(xdr->tail[0].iov_base);
> -		page_base = (unsigned long)xdr->tail[0].iov_base & ~PAGE_MASK;
> +		page_base = offset_in_page(xdr->tail[0].iov_base);
> 
> 		/* If the content in the page list is an odd length,
> 		 * xdr_write_pages() has added a pad at the beginning
> @@ -587,7 +587,7 @@ rpcrdma_prepare_msg_sges(struct rpcrdma_ia *ia, struct rpcrdma_req *req,
> 	 */
> 	if (xdr->tail[0].iov_len) {
> 		page = virt_to_page(xdr->tail[0].iov_base);
> -		page_base = (unsigned long)xdr->tail[0].iov_base & ~PAGE_MASK;
> +		page_base = offset_in_page(xdr->tail[0].iov_base);
> 		len = xdr->tail[0].iov_len;
> 
> map_tail:

There are several other sites that use PAGE_MASK in
rpc_rdma.c. Should those be included in this patch?

Do you have a way to test this change? If not I
can take it (once the above comment is addressed),
run it through the usual battery of NFS/RDMA
testing, and then pass it along to Anna.


> diff --git a/net/sunrpc/xprtrdma/svc_rdma_sendto.c b/net/sunrpc/xprtrdma/svc_rdma_sendto.c
> index 1736337..60b3f29 100644
> --- a/net/sunrpc/xprtrdma/svc_rdma_sendto.c
> +++ b/net/sunrpc/xprtrdma/svc_rdma_sendto.c
> @@ -306,12 +306,11 @@ static int svc_rdma_dma_map_buf(struct svcxprt_rdma *rdma,
> 				unsigned char *base,
> 				unsigned int len)
> {
> -	unsigned long offset = (unsigned long)base & ~PAGE_MASK;
> 	struct ib_device *dev = rdma->sc_cm_id->device;
> 	dma_addr_t dma_addr;
> 
> 	dma_addr = ib_dma_map_page(dev, virt_to_page(base),
> -				   offset, len, DMA_TO_DEVICE);
> +				   offset_in_page(base), len, DMA_TO_DEVICE);
> 	if (ib_dma_mapping_error(dev, dma_addr))
> 		return -EIO;
> 

This hunk conflicts with a rewrite of svc_rdma_sendto.c that
Bruce has already accepted for v4.12. I would prefer this
be dropped.

The rewritten code also has this issue. I can submit a patch
separately that adds offset_in_page in the appropriate place.


--
Chuck Lever

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] fs/ocfs2/cluster: use offset_in_page() macro Geliang Tang <geliangtang@gmail.com> - 2017-04-22 03:30 +0200
  [PATCH] xprtrdma: use offset_in_page() macro Geliang Tang <geliangtang@gmail.com> - 2017-04-22 03:30 +0200
    Re: [PATCH] xprtrdma: use offset_in_page() macro Chuck Lever <chuck.lever@oracle.com> - 2017-04-22 05:40 +0200
  [PATCH] tty/serial: atmel: use offset_in_page() macro Geliang Tang <geliangtang@gmail.com> - 2017-04-22 03:30 +0200
    Re: [PATCH] tty/serial: atmel: use offset_in_page() macro Richard Genoud <richard.genoud@gmail.com> - 2017-04-24 09:20 +0200

csiph-web