Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1623716

Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node

From Andrey Smirnov <andrew.smirnov@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node
Date 2017-04-14 17:30 +0200
Message-ID <twbkB-2J3-1@gated-at.bofh.it> (permalink)
References <tvN8B-3CF-3@gated-at.bofh.it> <tvN8B-3CF-9@gated-at.bofh.it> <tvVpv-Xu-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Apr 13, 2017 at 3:20 PM, Fabio Estevam <festevam@gmail.com> wrote:
> Hi Andrey,
>
> On Thu, Apr 13, 2017 at 10:32 AM, Andrey Smirnov
> <andrew.smirnov@gmail.com> wrote:
>
>> diff --git a/arch/arm/boot/dts/imx7d-sdb.dts b/arch/arm/boot/dts/imx7d-sdb.dts
>> index 5be01a1..e0ff276 100644
>> --- a/arch/arm/boot/dts/imx7d-sdb.dts
>> +++ b/arch/arm/boot/dts/imx7d-sdb.dts
>> @@ -52,6 +52,30 @@
>>                 reg = <0x80000000 0x80000000>;
>>         };
>>
>> +       spi4 {
>
> Here you use spi4 label...
>
>> +               compatible = "spi-gpio";
>> +               pinctrl-names = "default";
>> +               pinctrl-0 = <&pinctrl_spi1>;
>
> and here spi1, which is a bit confusing.
>

Agreed. It is confusing, will fix in v2.

>> +               status = "okay";
>> +               gpio-sck = <&gpio1 13 0>;
>> +               gpio-mosi = <&gpio1 9 0>;
>> +               cs-gpios = <&gpio1 12 0>;
>
> You could use GPIO_ACTIVE_HIGH flag for better readability.

Missed that, will fix in v2.

Thanks,
Andrey Smirnov

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-04-13 15:40 +0200
  Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Fabio Estevam <festevam@gmail.com> - 2017-04-14 00:30 +0200
    Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-04-14 17:30 +0200
  Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Shawn Guo <shawnguo@kernel.org> - 2017-04-14 05:50 +0200
    Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-04-14 17:40 +0200
    Re: [PATCH 6/8] ARM: dts: imx7d-sdb: Add GPIO expander node Dong Aisheng <dongas86@gmail.com> - 2017-04-14 18:10 +0200

csiph-web