Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1623367
| From | "Baicar, Tyler" <tbaicar@codeaurora.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 |
| Date | 2017-04-13 23:40 +0200 |
| Message-ID | <tvUD8-nL-19@gated-at.bofh.it> (permalink) |
| References | <tq58d-3Wt-3@gated-at.bofh.it> <tq58e-3Wt-33@gated-at.bofh.it> <tvqF3-51n-11@gated-at.bofh.it> <tvTH3-8b7-1@gated-at.bofh.it> <tvTQK-8fn-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 4/13/2017 2:47 PM, Borislav Petkov wrote: > On Thu, Apr 13, 2017 at 02:30:21PM -0600, Baicar, Tyler wrote: >> I do not agree with this. The struct being passed to this function is >> already named acpi_hest_generic_data in the existing code and all over this >> code is named gdata not just d. > And I'm saying they're too long - the preexisting ones and the ones > you're adding - and impair readability. This whole driver is one > unreadable ugly pile and if I were the maintainer I would never allowed > it in its current form. > > But I don't think it really has a maintainer - poor Rafael has to deal > with it because it is under drivers/acpi/ and that whole RAS firmware > crap got thrown over the wall at some point and now we're stuck with it. > > So this is just my opinion since he asked me to take a look. Okay, that makes sense. I'd prefer to avoid completely re-writing the existing code in this patch set :) Thanks, Tyler -- Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm Technologies, Inc. Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 Borislav Petkov <bp@alien8.de> - 2017-04-12 15:40 +0200
Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 Joe Perches <joe@perches.com> - 2017-04-12 18:50 +0200
Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 "Baicar, Tyler" <tbaicar@codeaurora.org> - 2017-04-13 22:40 +0200
Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 Borislav Petkov <bp@alien8.de> - 2017-04-13 22:50 +0200
Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data entry v3 per ACPI 6.1 "Baicar, Tyler" <tbaicar@codeaurora.org> - 2017-04-13 23:40 +0200
csiph-web