Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1623014

Re: [PATCH] powerpc/mm: Move page table dump into powerpc subdirectory

From Michael Ellerman <mpe@ellerman.id.au>
Newsgroups linux.kernel
Subject Re: [PATCH] powerpc/mm: Move page table dump into powerpc subdirectory
Date 2017-04-13 15:30 +0200
Message-ID <tvMYV-3yB-9@gated-at.bofh.it> (permalink)
References <tvMme-34k-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Christophe Leroy <christophe.leroy@c-s.fr> writes:

> Page table dump is a powerpc specific thing, so it should
> appear in powerpc/ subdirectory of debugfs

It's not powerpc specific. x86, arm, arm64 and s390 all have it.

But, I notice we somehow got the name wrong :}

All the other arches call it "kernel_page_tables".

> -	debugfs_file = debugfs_create_file("kernel_pagetables", 0400, NULL,
> -			NULL, &ptdump_fops);

¯\_(ツ)_/¯


So we probably should rename it to match the other arches. I would take
a patch for that.

cheers

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] powerpc/mm: Move page table dump into powerpc subdirectory Christophe Leroy <christophe.leroy@c-s.fr> - 2017-04-13 14:50 +0200
  Re: [PATCH] powerpc/mm: Move page table dump into powerpc subdirectory Michael Ellerman <mpe@ellerman.id.au> - 2017-04-13 15:30 +0200

csiph-web