Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1620668
| From | Steven Rostedt <rostedt@goodmis.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [for-next][PATCH 0/7] tracing: Stack tracing and rcu modification updates |
| Date | 2017-04-10 22:00 +0200 |
| Message-ID | <tuNDI-5ev-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/linux-trace.git
for-next
Head SHA1: d54b6eeb553c89ed8d4c5a2ed73df374a45b9562
Paul E. McKenney (1):
rcu: Fix dyntick-idle tracing
Steven Rostedt (VMware) (6):
ftrace: Add use of synchronize_rcu_tasks() with dynamic trampolines
tracing: Replace the per_cpu() with __this_cpu*() in trace_stack.c
tracing: Add stack_tracer_disable/enable() functions
tracing: Rename trace_active to disable_stack_tracer and inline its modification
rcu/tracing: Add rcu_disabled to denote when rcu_irq_enter() will not work
tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events
----
include/linux/ftrace.h | 38 ++++++++++++++++++++++++++++
include/linux/rcupdate.h | 5 ++++
include/linux/tracepoint.h | 19 ++++++++------
kernel/rcu/tree.c | 62 +++++++++++++++++++++++++++-------------------
kernel/trace/Kconfig | 3 ++-
kernel/trace/ftrace.c | 42 ++++++++++++++-----------------
kernel/trace/trace_stack.c | 35 +++++++++++++-------------
7 files changed, 128 insertions(+), 76 deletions(-)
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[for-next][PATCH 0/7] tracing: Stack tracing and rcu modification updates Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 6/7] rcu/tracing: Add rcu_disabled to denote when rcu_irq_enter() will not work Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 4/7] tracing: Rename trace_active to disable_stack_tracer and inline its modification Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
Re: [for-next][PATCH 4/7] tracing: Rename trace_active to disable_stack_tracer and inline its modification Valentin Rothberg <valentinrothberg@gmail.com> - 2017-04-13 10:00 +0200
Re: [for-next][PATCH 4/7] tracing: Rename trace_active to disable_stack_tracer and inline its modification Steven Rostedt <rostedt@goodmis.org> - 2017-04-13 16:10 +0200
[for-next][PATCH 7/7] tracing: Make sure rcu_irq_enter() can work for trace_*_rcuidle() trace events Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 5/7] rcu: Fix dyntick-idle tracing Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 1/7] ftrace: Add use of synchronize_rcu_tasks() with dynamic trampolines Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 3/7] tracing: Add stack_tracer_disable/enable() functions Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
[for-next][PATCH 2/7] tracing: Replace the per_cpu() with __this_cpu*() in trace_stack.c Steven Rostedt <rostedt@goodmis.org> - 2017-04-10 22:00 +0200
csiph-web