Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1612174

Re: [Outreachy kernel] [PATCH 1/4] iio: common: st_sensors: Replace ternary operator with min macro

From SIMRAN SINGHAL <singhalsimran0@gmail.com>
Newsgroups linux.kernel
Subject Re: [Outreachy kernel] [PATCH 1/4] iio: common: st_sensors: Replace ternary operator with min macro
Date 2017-03-29 19:30 +0200
Message-ID <tqpzY-1Bd-5@gated-at.bofh.it> (permalink)
References <tql3j-6Rq-3@gated-at.bofh.it> <tql3k-6Rq-25@gated-at.bofh.it> <tqoue-Wy-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Mar 29, 2017 at 9:46 PM, Daniel Baluta <daniel.baluta@gmail.com> wrote:
> On Wed, Mar 29, 2017 at 3:33 PM, simran singhal
> <singhalsimran0@gmail.com> wrote:
>> Use macro min() to get the minimum of two values for brevity and
>> readability.
>>
>> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
>> ---
>>  drivers/iio/common/st_sensors/st_sensors_i2c.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/iio/common/st_sensors/st_sensors_i2c.c b/drivers/iio/common/st_sensors/st_sensors_i2c.c
>> index c83df4d..7a68fdd 100644
>> --- a/drivers/iio/common/st_sensors/st_sensors_i2c.c
>> +++ b/drivers/iio/common/st_sensors/st_sensors_i2c.c
>> @@ -39,7 +39,7 @@ static int st_sensors_i2c_read_byte(struct st_sensor_transfer_buffer *tb,
>>         *res_byte = err & 0xff;
>>
>>  st_accel_i2c_read_byte_error:
>> -       return err < 0 ? err : 0;
>> +       return min(err, 0);
>>  }
>
> Appreciate the brevity but this certainly doesn't make code
> easier to read.
>
> In linux kernel err < 0 signifies an error and be replacing
> comparison < 0 with min() we some hide the meaning of this.
>
Yes, you are right keeping the previous one will be more
meaningful.

Thanks.

> thanks,
> Daniel.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/4] iio: common: st_sensors: Replace ternary operator with min macro simran singhal <singhalsimran0@gmail.com> - 2017-03-29 14:40 +0200
  Re: [Outreachy kernel] [PATCH 1/4] iio: common: st_sensors: Replace  ternary operator with min macro Daniel Baluta <daniel.baluta@gmail.com> - 2017-03-29 18:20 +0200
    Re: [Outreachy kernel] [PATCH 1/4] iio: common: st_sensors: Replace  ternary operator with min macro SIMRAN SINGHAL <singhalsimran0@gmail.com> - 2017-03-29 19:30 +0200

csiph-web