Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1611709
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/5] locking: Introduce range reader/writer lock |
| Date | 2017-03-29 11:10 +0200 |
| Message-ID | <tqhM6-4Lj-7@gated-at.bofh.it> (permalink) |
| References | <tigat-2NF-5@gated-at.bofh.it> <tihpT-3Xx-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Mar 06, 2017 at 09:03:26PM -0800, Davidlohr Bueso wrote: > +#define RANGE_RWLOCK_INFINITY (~0UL - 1) > +#define DEFINE_RANGE_RWLOCK_INF(name) \ > + struct range_rwlock name = __RANGE_RWLOCK_INITIALIZER(0, RANGE_RWLOCK_INFINITY) > +void range_rwlock_init_inf(struct range_rwlock *lock); Ayes I'm a pendant, but that's a very small infinity. I always thought infinity wasn't enumerable. Can we think of a different name here? 'whole' / 'all' / 'full' ?
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 1/5] locking: Introduce range reader/writer lock Peter Zijlstra <peterz@infradead.org> - 2017-03-29 11:10 +0200 Re: [PATCH 1/5] locking: Introduce range reader/writer lock Davidlohr Bueso <dave@stgolabs.net> - 2017-03-29 17:10 +0200
csiph-web