Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1613555
| From | Bjorn Helgaas <helgaas@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups |
| Date | 2017-03-31 01:50 +0200 |
| Message-ID | <tqRZg-5cy-19@gated-at.bofh.it> (permalink) |
| References | <tkywh-1es-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Mar 13, 2017 at 07:13:21PM +0530, Kishon Vijay Abraham I wrote: > This should be the final set of cleanups/fixes before endpoint > support can be merged. > > Keerthy's patch is a general fix in dra7xx driver and is not > directly related to endpoint mode. > > This v1 of this series was previously sent with a different > cover letter $subject [1] > > Changes from v3: > *) instead of changing all the callers of dbi accessors (taking > dbi_base and size), manage it using static inline as suggested > by Niklas (used static inline instead of macros because of > checkpatch error). > > Changes from v2: > *) Kconfig changes that was spilled into a patch is removed. > *) In addition to renaming _unroll() to _ob_unroll(), all the > _unroll configurations is also moved a separate function. > > Changes from v1: > *) included a patch to rename _unroll() to _ob_unroll() as > similar thing has to be done for inbound window in the case > of EP mode. > *) used 'size_t' instead of 'int' for specifying the size > in read_dbi/write_dbi function arguments. > *) Populate cpu_addr_fixup ops for artpec6 as suggested by > Niklas > > This series is based on 4.11-rc1 > > [1] -> https://lkml.org/lkml/2017/2/16/270 > > Keerthy (1): > PCI: dwc: dra7xx: Push request_irq call to the bottom of probe > > Kishon Vijay Abraham I (6): > PCI: dwc: designware: Add new *ops* for cpu addr fixup > PCI: dwc: dra7xx: Populate cpu_addr_fixup ops > PCI: dwc: artpec6: Populate cpu_addr_fixup ops > PCI: dwc: all: Modify dbi accessors to take dbi_base as argument > PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes > PCI: dwc: designware: Move _unroll configurations to a separate > function > > drivers/pci/dwc/pci-dra7xx.c | 25 +++---- > drivers/pci/dwc/pci-exynos.c | 14 ++-- > drivers/pci/dwc/pcie-artpec6.c | 15 +++-- > drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++-------------- > drivers/pci/dwc/pcie-designware.h | 23 +++++-- > 5 files changed, 135 insertions(+), 75 deletions(-) Applied to pci/host-designware for v4.12, with Niklas' ack on patches 4 & 5, thanks!
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Bjorn Helgaas <helgaas@kernel.org> - 2017-03-31 01:50 +0200 Re: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Kishon Vijay Abraham I <kishon@ti.com> - 2017-03-31 06:50 +0200
csiph-web