Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1609176

Re: selinux: Move some assignments for the variable "rc" in policydb_read()

From Paul Moore <paul@paul-moore.com>
Newsgroups linux.kernel
Subject Re: selinux: Move some assignments for the variable "rc" in policydb_read()
Date 2017-03-25 16:40 +0100
Message-ID <toVXk-2KE-5@gated-at.bofh.it> (permalink)
References <sZUrL-3Jh-9@gated-at.bofh.it> <sZUL9-44S-49@gated-at.bofh.it> <toiMh-8kl-5@gated-at.bofh.it> <touu5-8u8-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Mar 24, 2017 at 6:09 AM, SF Markus Elfring
<elfring@users.sourceforge.net> wrote:
>>> One local variable was set to an error code in some cases before
>>> a concrete error situation was detected. Thus move the corresponding
>>> assignments into if branches to indicate a software failure there.
>>>
>>> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
>>> ---
>>>  security/selinux/ss/policydb.c | 59 +++++++++++++++++++++++++-----------------
>>>  1 file changed, 35 insertions(+), 24 deletions(-)
>>
>> More code churn with no real advantage.
>
> There are different opinions about the mentioned implementation details.
>
>> I agree with the style you are using,
>
> Thanks for such feedback.
>
>> and would support changing it if you are in the function fixing bugs
>> or doing other substantial changes in that code,
>
> Is this expectation a contradiction for a desired patch granularity?
>
>> but I can't justify it as a standalone change, sorry.
>
> This update suggestion seems to be not attractive enough for you at the moment
> as another change step of my patch series.
> Would you like to check if there are other effects worthwhile besides the proposed
> coding style adjustment here?

To be honest, I would just leave it alone for now.  If you want to
contribute, focus on meaningful improvements such as bug fixing and/or
new features; changing only the code style isn't very interesting or
appealing, even if I happen to agree with your changes.

-- 
paul moore
www.paul-moore.com

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 10/46] selinux: Move some assignments for the variable  "rc" in policydb_read() Paul Moore <paul@paul-moore.com> - 2017-03-23 22:50 +0100
  Re: selinux: Move some assignments for the variable "rc" in  policydb_read() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-03-24 11:20 +0100
    Re: selinux: Move some assignments for the variable "rc" in policydb_read() Paul Moore <paul@paul-moore.com> - 2017-03-25 16:40 +0100

csiph-web