Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1608923
| From | Julius Werner <jwerner@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 4/5] firmware: Add coreboot device tree binding documentation |
| Date | 2017-03-24 20:40 +0100 |
| Message-ID | <toDe2-6aU-5@gated-at.bofh.it> (permalink) |
| References | <toi9A-84L-13@gated-at.bofh.it> <toi9B-84L-39@gated-at.bofh.it> <towvU-1tO-11@gated-at.bofh.it> <toBFf-50v-9@gated-at.bofh.it> <toDe2-6aU-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
...and again in plaintext, sorry about that. On Fri, Mar 24, 2017 at 12:32 PM, Julius Werner <jwerner@chromium.org> wrote: >> > Devicetree bindings should be in vendor,prefix format. This doesn't >> > represent every aspect of coreboot, so it needs a more descriptive >> > string. >> >> Any particular suggestion? I suppose this is Google's interpretation of >> coreboot tables, so "google,coreboot"? > > > No. This binding is for the coreboot project in general and has nothing to > do with Google. coreboot is both the vendor and the product, so I think > "coreboot" would look better than "coreboot,coreboot". And yes, it is > supposed to represent every aspect of coreboot (right now the "coreboot > tables" are already sort of a catch-all data structure used by coreboot to > pass on any sort of info it wants later stages to know... and if we ever > have any additional things we'd like to pass on, we'd probably want to add > them to this binding as well). > >> >> > > + - reg: Address and length of the following two memory regions, in >> > > order: >> > > + 1.) The coreboot table. This is a list of variable-sized >> > > descriptors >> > > + that contain various compile- and run-time generated firmware >> > > + parameters. It is identified by the magic string "LBIO" in its >> > > first >> > > + four bytes. >> > > + See coreboot's src/commonlib/include/commonlib/coreboot_tables.h >> > > for >> > > + details. >> > >> > Given this is a memory region, it should be described under the >> > reserved-memory node. >> >> We've painted this bikeshed before. I guess the result was either to use >> /reserved-memory or /memreserve/. I believe we've been using >> /memreserve/. I suppose we could document a method to use either, but >> the main "agreement" was to use the /firmware/coreboot path instead of >> /reserved-memory/coreboot. > > > See the old thread Brian linked for some arguments for and against this. I > think particularly because we want this node to represent every aspect of > coreboot (which I think makes more sense than spreading stuff all over the > place), treating it as reserved memory would not work well if we might later > add other fields. > > Also, since we didn't get any more responses the last time we tried to > upstream this and had schedules to keep, we had to go ahead with what we > had. So right now there are already millions of devices shipped with this > binding in firmware, and the only question we still have left to decide is > whether Linux wants to support them upstream or not.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/5] firmware: google memconsole Thierry Escande <thierry.escande@collabora.com> - 2017-03-23 22:10 +0100
[PATCH 4/5] firmware: Add coreboot device tree binding documentation Thierry Escande <thierry.escande@collabora.com> - 2017-03-23 22:10 +0100
Re: [PATCH 4/5] firmware: Add coreboot device tree binding documentation Mark Rutland <mark.rutland@arm.com> - 2017-03-24 13:30 +0100
Re: [PATCH 4/5] firmware: Add coreboot device tree binding documentation Brian Norris <briannorris@chromium.org> - 2017-03-24 19:00 +0100
Re: [PATCH 4/5] firmware: Add coreboot device tree binding documentation Julius Werner <jwerner@chromium.org> - 2017-03-24 20:40 +0100
[PATCH 5/5] firmware: google memconsole: Add ARM/ARM64 support Thierry Escande <thierry.escande@collabora.com> - 2017-03-23 22:10 +0100
Re: [PATCH 5/5] firmware: google memconsole: Add ARM/ARM64 support Mark Rutland <mark.rutland@arm.com> - 2017-03-24 13:30 +0100
Re: [PATCH 5/5] firmware: google memconsole: Add ARM/ARM64 support Brian Norris <briannorris@chromium.org> - 2017-03-24 19:10 +0100
Re: [PATCH 5/5] firmware: google memconsole: Add ARM/ARM64 support Julius Werner <jwerner@chromium.org> - 2017-03-24 21:00 +0100
Re: [PATCH 5/5] firmware: google memconsole: Add ARM/ARM64 support Brian Norris <briannorris@chromium.org> - 2017-03-27 19:00 +0200
[PATCH 3/5] firmware: google memconsole: Add coreboot support Thierry Escande <thierry.escande@collabora.com> - 2017-03-23 22:10 +0100
[PATCH 1/5] firmware: google memconsole: Remove useless submenu in Kconfig Thierry Escande <thierry.escande@collabora.com> - 2017-03-23 22:10 +0100
csiph-web