Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1607226

Re: [PATCH 0/3] staging: media: Replace a bit shift.

From Chris Moore <moore@free.fr>
Newsgroups linux.kernel
Subject Re: [PATCH 0/3] staging: media: Replace a bit shift.
Date 2017-03-23 09:10 +0100
Message-ID <to5YK-7Ts-21@gated-at.bofh.it> (permalink)
References <tnG4h-5dV-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

Le 22/03/2017 à 05:26, Arushi Singhal a écrit :
> Replace a bit shift by a use of BIT in media driver.
>
> Arushi Singhal (3):
>    staging: media: Replace a bit shift by a use of BIT.
>    staging: media: davinci_vpfe: Replace a bit shift by a use of BIT.
>    staging: media: omap4iss: Replace a bit shift by a use of BIT.
>
>   .../media/atomisp/pci/atomisp2/atomisp_cmd.c       | 12 +++++-----
>   .../atomisp/pci/atomisp2/atomisp_compat_css20.c    |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_drvfs.c     |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_v4l2.c      | 18 +++++++--------
>   .../media/atomisp/pci/atomisp2/hmm/hmm_bo.c        |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipe.c   |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipeif.c |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_isif.c    | 26 +++++++++++-----------
>   drivers/staging/media/davinci_vpfe/dm365_resizer.c |  6 ++---
>   drivers/staging/media/omap4iss/iss_csi2.c          |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipe.c         |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipeif.c       |  2 +-
>   drivers/staging/media/omap4iss/iss_resizer.c       |  2 +-
>   13 files changed, 44 insertions(+), 44 deletions(-)
>

Most of these replacements add redundant parentheses around the BIT macro.
IMHO this makes the code less readable.
So I suggest (BIT(c)) -> BIT(c).

Cheers,
Chris

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 0/3] staging: media: Replace a bit shift. Arushi Singhal <arushisinghal19971997@gmail.com> - 2017-03-22 05:30 +0100
  [PATCH 2/3] staging: media: davinci_vpfe: Replace a bit shift by a use of BIT. Arushi Singhal <arushisinghal19971997@gmail.com> - 2017-03-22 05:40 +0100
  [PATCH 3/3] staging: media: omap4iss: Replace a bit shift by a use of BIT. Arushi Singhal <arushisinghal19971997@gmail.com> - 2017-03-22 05:40 +0100
  [PATCH 1/3] staging: media: Replace a bit shift by a use of BIT. Arushi Singhal <arushisinghal19971997@gmail.com> - 2017-03-22 05:40 +0100
  Re: [PATCH 0/3] staging: media: Replace a bit shift. Chris Moore <moore@free.fr> - 2017-03-23 09:10 +0100

csiph-web