Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1605917
| Path | csiph.com!weretis.net!feeder4.news.weretis.net!news.unit0.net!news.panservice.it!diesel.cu.mi.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Geert Uytterhoeven <geert@linux-m68k.org> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 1/2] backlight: pwm_bl: Move the checks for initial power state to a separate function |
| Date | Tue, 21 Mar 2017 20:00:02 +0100 |
| Message-ID | <tnxaG-7fa-7@gated-at.bofh.it> (permalink) |
| References | <sGjCp-7LM-9@gated-at.bofh.it> <sGjCp-7LM-7@gated-at.bofh.it> |
| X-Original-To | Peter Ujfalusi <peter.ujfalusi@ti.com>, Lee Jones <lee.jones@linaro.org> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:cc; bh=gPnckMg2gvZCY3RmJHXSKWD71L2LGGs5IcYvM5OOPPI=; b=afkSeORghrEYy1SKfAcs0iOYzmuyw81KX80GVbs/cR6y/eiolV0NF6OeD5HLUToqXV b2zUiMIbOChpXG1x+NeedKFceI0cqZkEAq8XWRD1OM5N3cf+zpytZaslRsRJCRY9fzoR x8SHDHWVRLeXY7L+gXM9uTbOYwpofeHLXZbIHqaLrQJniFLzjhQG2lAxIIofIlHCzTzC csMKnNysZP+MR9L475ST/lXVZ0z8n5Gw/wiHoFeNkfQbjsbO+9rHlsBiD/mO80ulYAZM tWLupSmRtUD95DCmWKuz42WVNzIAgYahxFVUE6kVaa/GP9UTiAEi8u5OdoIAjF0ozGNX +8Aw== |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:sender:in-reply-to:references:from :date:message-id:subject:to:cc; bh=gPnckMg2gvZCY3RmJHXSKWD71L2LGGs5IcYvM5OOPPI=; b=a8Sq/GbP6HlC19LhAMxUyt9vPziYgwfYJapLhqL04NMHu2LgX/uhMMJQo9J21e/1iO Q126HDEcVYfKLTrZZOhC58YWIKfuS/NOXXtFFGmdpHj543Iq3wV9cixfjjLxzZz2QlaY FURyRi8cKjQb7mbhis46TzD/RLuAbILSYCCyaz43+1q3v0ycyhHwoDkp7HPJSOwqi7th /krGKJkMU7bYv3+pYIgOhLme/2A3EaK6oL+L6sBnDwRd8IEMTYXsOILOgy9YY3fcm8M9 8wyRcIrbhYjtjUs1JtDIaaQx9yVE72peFrBvj5jK0vXcSwg88y+wMv4BkaQPZNub93gH mK9g== |
| X-Gm-Message-State | AFeK/H30sCbtmFNRKlRYElqPaqQzss2BvHVUoir+WZW+/L+9LBdANq7s2wItA2+3HFfhQRtz0rWfkidoOexVyg== |
| X-Received | by 10.36.88.200 with SMTP id f191mr91307itb.74.1490122130413; Tue, 21 Mar 2017 11:48:50 -0700 (PDT) |
| MIME-Version | 1.0 |
| X-Google-Sender-Auth | gJacf54myGT6S_Eh0c4GwGCoHe4 |
| Content-Type | text/plain; charset=UTF-8 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 87 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Thierry Reding <thierry.reding@gmail.com>, Tomi Valkeinen <tomi.valkeinen@ti.com>, Linux PWM List <linux-pwm@vger.kernel.org>, Linux Fbdev development list <linux-fbdev@vger.kernel.org>, "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>, Philipp Zabel <p.zabel@pengutronix.de>, Linus Walleij <linus.walleij@linaro.org>, "linux-gpio@vger.kernel.org" <linux-gpio@vger.kernel.org>, Linux-Renesas <linux-renesas-soc@vger.kernel.org> |
| X-Original-Date | Tue, 21 Mar 2017 19:48:49 +0100 |
| X-Original-Message-ID | <CAMuHMdXcgWyKqhZFX49Ri1eEgi1_8b_xj6P9vKwEBwpsxMXTuA@mail.gmail.com> |
| X-Original-References | <20161122134123.1209-1-peter.ujfalusi@ti.com> <20161122134123.1209-2-peter.ujfalusi@ti.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1605917 |
Show key headers only | View raw
Hi Peter,
On Tue, Nov 22, 2016 at 2:41 PM, Peter Ujfalusi <peter.ujfalusi@ti.com> wrote:
> Move the checks to select the initial state for the backlight to a new
> function and document the checks we are doing.
This is far from a simple "move"...
> With the separate function it is going to be easier to fix or improve the
> initial power state configuration later and it is easier to read the code.
>
> Signed-off-by: Peter Ujfalusi <peter.ujfalusi@ti.com>
> Reviewed-by: Philipp Zabel <p.zabel@pengutronix.de>
> Reviewed-by: Thierry Reding <treding@nvidia.com>
This patch (commit 7613c922315e308a in v4.11-rc1) broke the display on
r8a7740/armadillo.
> @@ -267,20 +292,16 @@ static int pwm_backlight_probe(struct platform_device *pdev)
> pb->enable_gpio = gpio_to_desc(data->enable_gpio);
> }
>
> - if (pb->enable_gpio) {
> - /*
> - * If the driver is probed from the device tree and there is a
> - * phandle link pointing to the backlight node, it is safe to
> - * assume that another driver will enable the backlight at the
> - * appropriate time. Therefore, if it is disabled, keep it so.
> - */
> - if (node && node->phandle &&
> - gpiod_get_direction(pb->enable_gpio) == GPIOF_DIR_OUT &&
> - gpiod_get_value(pb->enable_gpio) == 0)
> - initial_blank = FB_BLANK_POWERDOWN;
> - else
> - gpiod_direction_output(pb->enable_gpio, 1);
In my case, "node" points to the "/backlight" node, but phandle is NULL.
Hence before, gpiod_direction_output() was called to enable the GPIO...
> - }
> + /*
> + * If the GPIO is configured as input, change the direction to output
> + * and set the GPIO as active.
> + * Do not force the GPIO to active when it was already output as it
> + * could cause backlight flickering or we would enable the backlight too
> + * early. Leave the decision of the initial backlight state for later.
> + */
> + if (pb->enable_gpio &&
> + gpiod_get_direction(pb->enable_gpio) == GPIOF_DIR_IN)
> + gpiod_direction_output(pb->enable_gpio, 1);
... while now it's no longer called, as gpiod_get_direction() returns
-EINVAL.
Indeed, r8a7740_pfc does not implement the .get_direction() callback,
so gpiod_get_direction() always returns -EINVAL, which is never equal
to GPIOF_DIR_IN.
Restoring the old behavior by changing the above test to
if (pb->enable_gpio &&
(!node || !node->phandle ||
gpiod_get_direction(pb->enable_gpio) == GPIOF_DIR_IN))
fixes the display for me, but leads to a more complex expression.
However, changing the test to
if (pb->enable_gpio &&
gpiod_get_direction(pb->enable_gpio) != GPIOF_DIR_OUT)
also fixes the display, as an error is always different from GPIOF_DIR_OUT.
Anyone with comments or suggestions to fix this for real?
Thanks!
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH v4 1/2] backlight: pwm_bl: Move the checks for initial power state to a separate function Geert Uytterhoeven <geert@linux-m68k.org> - 2017-03-21 20:00 +0100
Re: [PATCH v4 1/2] backlight: pwm_bl: Move the checks for initial power state to a separate function Philipp Zabel <p.zabel@pengutronix.de> - 2017-03-22 12:10 +0100
Re: [PATCH v4 1/2] backlight: pwm_bl: Move the checks for initial power state to a separate function Geert Uytterhoeven <geert@linux-m68k.org> - 2017-03-22 13:40 +0100
csiph-web