Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1605689
| From | Christophe LEROY <christophe.leroy@c-s.fr> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] powerpc: sysdev: cpm1: Optimise gpio bit calculation |
| Date | 2017-03-21 16:10 +0100 |
| Message-ID | <tntA6-4ZS-11@gated-at.bofh.it> (permalink) |
| References | (3 earlier) <tjsCC-4wB-25@gated-at.bofh.it> <tjtp0-56o-15@gated-at.bofh.it> <tjtS4-5k0-61@gated-at.bofh.it> <tju1H-5nB-1@gated-at.bofh.it> <tjuXL-63f-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Le 10/03/2017 à 16:41, Segher Boessenkool a écrit : > On Fri, Mar 10, 2017 at 03:41:23PM +0100, Christophe LEROY wrote: >>>>>> gpio_get() and gpio_set() are used extensively by some GPIO based >>>>>> drivers like SPI, NAND, so it may be worth it as it doesn't impair >>>>>> readability (if anyone prefers, we could write (1 << 31) >> i instead >>>>>> of 0x80000000 >> i ) >>>>> 1 << 31 is undefined behaviour, of course. >>>> Shall it be 1U << 31 ? >>> Sure, that works. "1 << (31 - i)" is most readable (but it doesn't yet >>> generate the code you want). >> Euh .... I'm a bit lost. Do you mean the form we have today is the >> driver is wrong ? > Heh, yes. But is't okay with GCC, so don't worry about it. > > The point is that "0x80000000 >> i" is less readable. > > FYI, see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80131 Christophe
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH] powerpc: sysdev: cpm1: Optimise gpio bit calculation Christophe LEROY <christophe.leroy@c-s.fr> - 2017-03-21 16:10 +0100
csiph-web