Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1604733
| From | Thomas Gleixner <tglx@linutronix.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID |
| Date | 2017-03-20 17:20 +0100 |
| Message-ID | <tn8ch-7du-15@gated-at.bofh.it> (permalink) |
| References | <tn0HL-1Xo-1@gated-at.bofh.it> <tn8ch-7du-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, 20 Mar 2017, Kyle Huey wrote:
> --- a/arch/x86/include/uapi/asm/prctl.h
> +++ b/arch/x86/include/uapi/asm/prctl.h
> @@ -6,8 +6,17 @@
> #define ARCH_GET_FS 0x1003
> #define ARCH_GET_GS 0x1004
>
> +#define ARCH_GET_CPUID 0x1005
> +#define ARCH_SET_CPUID 0x1006
> +
> #define ARCH_MAP_VDSO_X32 0x2001
> #define ARCH_MAP_VDSO_32 0x2002
> #define ARCH_MAP_VDSO_64 0x2003
>
> +#ifdef CONFIG_CHECKPOINT_RESTORE
> +# define ARCH_MAP_VDSO_X32 0x2001
> +# define ARCH_MAP_VDSO_32 0x2002
> +# define ARCH_MAP_VDSO_64 0x2003
> +#endif
That hunk is bogus in two aspects:
- It's just a copy of the above wrapped in a ifdef
- The ifdef is broken, because the UAPI headers do not know about
that.
I dropped it.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v16 0/10] x86/arch_prctl Add ARCH_[GET|SET]_CPUID for controlling the CPUID instruction Kyle Huey <me@kylehuey.com> - 2017-03-20 09:20 +0100
[PATCH v16 01/10] x86/msr: Rename MISC_FEATURE_ENABLES to MISC_FEATURES_ENABLES Kyle Huey <me@kylehuey.com> - 2017-03-20 09:20 +0100
[tip:x86/process] x86/msr: Rename MISC_FEATURE_ENABLES to MISC_FEATURES_ENABLES tip-bot for Kyle Huey <tipbot@zytor.com> - 2017-03-20 17:40 +0100
[PATCH v16 10/10] KVM: x86: virtualize cpuid faulting Kyle Huey <me@kylehuey.com> - 2017-03-20 09:40 +0100
[PATCH v16 09/10] x86/arch_prctl: Selftest for ARCH_[GET|SET]_CPUID Kyle Huey <me@kylehuey.com> - 2017-03-20 16:50 +0100
Re: [PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID Thomas Gleixner <tglx@linutronix.de> - 2017-03-20 17:20 +0100
Re: [PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID Kyle Huey <me@kylehuey.com> - 2017-03-20 18:00 +0100
[PATCH v16 04/10] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64 Kyle Huey <me@kylehuey.com> - 2017-03-20 17:50 +0100
[PATCH v16 08/10] x86/arch_prctl: Add ARCH_[GET|SET]_CPUID Kyle Huey <me@kylehuey.com> - 2017-03-20 17:50 +0100
[PATCH v16 02/10] x86/arch_prctl: Rename 'code' argument to 'option' Kyle Huey <me@kylehuey.com> - 2017-03-20 17:50 +0100
[PATCH v16 05/10] x86/arch_prctl: Add do_arch_prctl_common Kyle Huey <me@kylehuey.com> - 2017-03-20 17:50 +0100
[PATCH v16 07/10] x86/cpufeature: Detect CPUID faulting support Kyle Huey <me@kylehuey.com> - 2017-03-20 17:50 +0100
[PATCH v16 03/10] x86/arch_prctl/64: Use SYSCALL_DEFINE2 to define sys_arch_prctl Kyle Huey <me@kylehuey.com> - 2017-03-20 18:00 +0100
[PATCH v16 06/10] x86/syscalls/32: Wire up arch_prctl on x86-32 Kyle Huey <me@kylehuey.com> - 2017-03-20 18:00 +0100
csiph-web