Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1603596
| From | Laura Abbott <labbott@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 08/12] cma: Store a name in the cma structure |
| Date | 2017-03-17 21:00 +0100 |
| Message-ID | <tm6cx-33T-1@gated-at.bofh.it> (permalink) |
| References | <tgGLL-8cb-5@gated-at.bofh.it> <tgGLM-8cb-9@gated-at.bofh.it> <tjoz0-1oL-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 03/10/2017 12:53 AM, Sumit Semwal wrote:
> Hi Laura,
>
> Thanks for the patch.
>
> On 3 March 2017 at 03:14, Laura Abbott <labbott@redhat.com> wrote:
>>
>> Frameworks that may want to enumerate CMA heaps (e.g. Ion) will find it
>> useful to have an explicit name attached to each region. Store the name
>> in each CMA structure.
>>
>> Signed-off-by: Laura Abbott <labbott@redhat.com>
>> ---
>> drivers/base/dma-contiguous.c | 5 +++--
>> include/linux/cma.h | 4 +++-
>> mm/cma.c | 11 +++++++++--
>> mm/cma.h | 1 +
>> mm/cma_debug.c | 2 +-
>> 5 files changed, 17 insertions(+), 6 deletions(-)
>>
> <snip>
>> +const char *cma_get_name(const struct cma *cma)
>> +{
>> + return cma->name ? cma->name : "(undefined)";
>> +}
>> +
> Would it make sense to perhaps have the idx stored as the name,
> instead of 'undefined'? That would make sure that the various cma
> names are still unique.
>
Good suggestion. I'll see about cleaning that up.
>> static unsigned long cma_bitmap_aligned_mask(const struct cma *cma,
>> int align_order)
>> {
>> @@ -168,6 +173,7 @@ core_initcall(cma_init_reserved_areas);
>> */
>> int __init cma_init_reserved_mem(phys_addr_t base, phys_addr_t size,
>> unsigned int order_per_bit,
>> + const char *name,
>> struct cma **res_cma)
>> {
>
> Best regards,
> Sumit.
>
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [RFC PATCH 08/12] cma: Store a name in the cma structure Laura Abbott <labbott@redhat.com> - 2017-03-17 21:00 +0100
csiph-web