Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1603445
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine |
| Date | 2017-03-17 17:40 +0100 |
| Message-ID | <tm350-Ro-3@gated-at.bofh.it> (permalink) |
| References | <tkUZQ-Q3-21@gated-at.bofh.it> <tkUZQ-Q3-19@gated-at.bofh.it> <tli66-po-5@gated-at.bofh.it> <tlDNg-7rG-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Mar 16, 2017 at 8:33 AM, Andrey Smirnov <andrew.smirnov@gmail.com> wrote: > On Wed, Mar 15, 2017 at 7:18 AM, Rob Herring <robh@kernel.org> wrote: >> On Tue, Mar 14, 2017 at 8:48 AM, Andrey Smirnov >> <andrew.smirnov@gmail.com> wrote: >>> Add serdev_device_write() which is a blocking call allowing to transfer >>> arbitraty amount of data (potentially exceeding amount that >>> serdev_device_write_buf can process in a single call) >>> >>> Cc: cphealy@gmail.com >>> Cc: Guenter Roeck <linux@roeck-us.net> >>> Cc: linux-serial@vger.kernel.org >>> Cc: linux-kernel@vger.kernel.org >>> Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> >>> --- >>> drivers/tty/serdev/core.c | 37 +++++++++++++++++++++++++++++++++++++ >>> include/linux/serdev.h | 23 +++++++++++++++++------ >>> 2 files changed, 54 insertions(+), 6 deletions(-) >>> >>> diff --git a/drivers/tty/serdev/core.c b/drivers/tty/serdev/core.c >>> index f4c6c90..759e834 100644 >>> --- a/drivers/tty/serdev/core.c >>> +++ b/drivers/tty/serdev/core.c >>> @@ -128,6 +128,41 @@ int serdev_device_write_buf(struct serdev_device *serdev, >>> } >>> EXPORT_SYMBOL_GPL(serdev_device_write_buf); >>> >>> +int serdev_device_write(struct serdev_device *serdev, >>> + const unsigned char *buf, size_t count) >> >> _write vs. _write_buf are not all that clear what the difference is. >> but I don't have a better name. >> > > serdev_device_send? send vs. write_buf? Still not that clear. >> Perhaps a timeout param is needed? This could never complete if CTS >> remains deasserted. > > Yeah, I think it is a good idea, I'll add that in v2. Maybe just combine the 2 functions and a timeout of 0 follows the original behavior of serdev_device_write_buf. I'm not sure if we could handle write_wakeup in that case though. Rob
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 1/2] serdev: Add serdev_device_write subroutine Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-03-14 14:50 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-03-15 00:20 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-03-16 15:30 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-03-16 16:10 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-03-17 14:40 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Rob Herring <robh@kernel.org> - 2017-03-15 15:30 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Andrey Smirnov <andrew.smirnov@gmail.com> - 2017-03-16 14:40 +0100
Re: [PATCH 1/2] serdev: Add serdev_device_write subroutine Rob Herring <robh@kernel.org> - 2017-03-17 17:40 +0100
csiph-web