Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1603320
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2] ASoC: rt286: fix headphone click/crack noise on Dell XPS 9343 I2S mode |
| Date | 2017-03-17 14:50 +0100 |
| Message-ID | <tm0qt-7b2-9@gated-at.bofh.it> (permalink) |
| References | <tlzgB-45R-7@gated-at.bofh.it> <tlEpY-7Wz-13@gated-at.bofh.it> <tm0qt-7b2-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
On Fri, Mar 17, 2017 at 02:41:04AM +0000, Kai-Heng Feng wrote: > On Thu, Mar 16, 2017 at 10:09 PM Mark Brown <broonie@kernel.org> wrote: > > > + rt286->is_dell_dino = dmi_check_system(dmi_dell_dino) ? true : > > false; > > Just directly assign the boolean value, the ternery operator is just > > making thins harder to read here. > Should I make the int implicitly convert to bool or use '!!' operator? Use implicit conversion like you're already doing - the above already evaluates the function as a boolean in order to use it in the ternery operator.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2] ASoC: rt286: fix headphone click/crack noise on Dell XPS 9343 I2S mode Kai-Heng Feng <kai.heng.feng@canonical.com> - 2017-03-16 09:50 +0100
Re: [PATCH v2] ASoC: rt286: fix headphone click/crack noise on Dell XPS 9343 I2S mode Mark Brown <broonie@kernel.org> - 2017-03-16 15:20 +0100
Re: [PATCH v2] ASoC: rt286: fix headphone click/crack noise on Dell XPS 9343 I2S mode Mark Brown <broonie@kernel.org> - 2017-03-17 14:50 +0100
csiph-web