Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1595159

Re: [RFC PATCH] sched/wait: Introduce new, more compact wait_event*() primitives

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [RFC PATCH] sched/wait: Introduce new, more compact wait_event*() primitives
Date 2017-03-08 14:20 +0100
Message-ID <tiJFw-73D-23@gated-at.bofh.it> (permalink)
References <tgKZ3-2I4-3@gated-at.bofh.it> <th1Qe-6jM-9@gated-at.bofh.it> <tix1E-6vP-9@gated-at.bofh.it> <tiFsd-3Rn-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Ingo Molnar <mingo@kernel.org> wrote:

> You can find the latest (WIP, frequently rebased) version in:
> 
>   git git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git WIP.sched/core
> 
> The first 10 patches reshape the waitqueue code to be more hackable (to me!), 
> because I kept bumping into confusing names all the time, but the real change 
> you'd be most interested in is, in an RFC (to be rebased!) form, the following 
> one:
> 
>   0c32c5717beb sched/wait: Introduce new, more compact wait_event*() primitives
> 
> I've attached that patch below as well.

Note that I rebased it meanwhile so the SHA1's changed. The commit titles should 
still be the same though.

Thanks,

	Ingo

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [GIT PULL] sched.h split-up Linus Torvalds <torvalds@linux-foundation.org> - 2017-03-03 21:20 +0100
  Re: [GIT PULL] sched.h split-up Ingo Molnar <mingo@kernel.org> - 2017-03-04 08:40 +0100
  Re: [GIT PULL] sched.h split-up Linus Torvalds <torvalds@linux-foundation.org> - 2017-03-08 00:50 +0100
    Re: [GIT PULL] sched.h split-up Linus Torvalds <torvalds@linux-foundation.org> - 2017-03-08 01:20 +0100
      Re: [GIT PULL] sched.h split-up Ingo Molnar <mingo@kernel.org> - 2017-03-08 18:30 +0100
    [RFC PATCH] sched/wait: Introduce new, more compact wait_event*()  primitives Ingo Molnar <mingo@kernel.org> - 2017-03-08 09:50 +0100
      [RFC PATCH] sched/wait: Add <linux/sched/signal.h> dependency for now Ingo Molnar <mingo@kernel.org> - 2017-03-08 10:30 +0100
        [PATCH -v2] sched/wait: Add <linux/sched/signal.h> dependency for now Ingo Molnar <mingo@kernel.org> - 2017-03-08 11:20 +0100
      [RFC PATCH, -v2] sched/wait: Introduce new, more compact  wait_event*() primitives Ingo Molnar <mingo@kernel.org> - 2017-03-08 13:30 +0100
        Re: [RFC PATCH, -v2] sched/wait: Introduce new, more compact  wait_event*() primitives Peter Zijlstra <peterz@infradead.org> - 2017-03-09 17:30 +0100
      Re: [RFC PATCH] sched/wait: Introduce new, more compact  wait_event*() primitives Ingo Molnar <mingo@kernel.org> - 2017-03-08 14:20 +0100
      Re: [RFC PATCH] sched/wait: Introduce new, more compact wait_event*() primitives Linus Torvalds <torvalds@linux-foundation.org> - 2017-03-08 17:40 +0100
        Re: [RFC PATCH] sched/wait: Introduce new, more compact  wait_event*() primitives Ingo Molnar <mingo@kernel.org> - 2017-03-08 18:20 +0100

csiph-web