Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1590517
| From | Linus Torvalds <torvalds@linux-foundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] objtool, module: discard __unreachable section for modules |
| Date | 2017-03-01 18:10 +0100 |
| Message-ID | <tgfVf-65H-5@gated-at.bofh.it> (permalink) |
| References | <tgemu-4Vt-15@gated-at.bofh.it> <tgfBT-5HN-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Mar 1, 2017 at 8:44 AM, <hpa@zytor.com> wrote:
>
> I would like to see a name like, say, ".annot.unreachable", since is odds are pretty high we are going to need more annotations in the future.
Why not just make it ".discard.unreachable", and then make the discard
pattern be ".discard*".
We already have .discard.text for some trace hackery, so it follows a pattern.
And that's what we do for things like .rodata.* etc.
In fact, we already have a pattern for '.discard.*' in the main
vmlinux.lds.h file exactly for the .discard.text case (but not for
modules, it looks like).
Linus
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] objtool, module: discard __unreachable section for modules Josh Poimboeuf <jpoimboe@redhat.com> - 2017-03-01 16:30 +0100
Re: [PATCH] objtool, module: discard __unreachable section for modules hpa@zytor.com - 2017-03-01 17:50 +0100
Re: [PATCH] objtool, module: discard __unreachable section for modules Linus Torvalds <torvalds@linux-foundation.org> - 2017-03-01 18:10 +0100
Re: [PATCH] objtool, module: discard __unreachable section for modules hpa@zytor.com - 2017-03-01 18:50 +0100
[PATCH v2] objtool, module: discard objtool annotation sections for modules Josh Poimboeuf <jpoimboe@redhat.com> - 2017-03-01 19:30 +0100
[tip:core/urgent] objtool, modules: Discard objtool annotation sections for modules tip-bot for Josh Poimboeuf <tipbot@zytor.com> - 2017-03-01 22:50 +0100
csiph-web