Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1584759

[PATCH 0/7] memory: atmel-ebi: Add PM ops

From Boris Brezillon <boris.brezillon@free-electrons.com>
Newsgroups linux.kernel
Subject [PATCH 0/7] memory: atmel-ebi: Add PM ops
Date 2017-02-20 18:10 +0100
Message-ID <tcZtF-7aS-49@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Hello,

This patchset adds a ->resume() hook to the EBI driver, but a few more
changes were required in order to easily implement this PM hook.

Patches 1 to 5 are just cleanup patches to simplify the EBI driver.
Patch 6 is fixing a bug in the EBI driver. Note that this bug has no
consequences until we start implementing the ->resume() hook.
And finally, patch 7 is implementing ->resume() so that the SMC config
is correctly restored when resuming the system.

This patchset depends on [1] which is removing the unused pata_at91
driver, which in turn prevents us from patching it before dropping
the old SMC macro definitions in patch 4.

Regards,

Boris

[1]http://lkml.iu.edu/hypermail/linux/kernel/1702.2/00990.html

Boris Brezillon (7):
  mfd: syscon: atmel-smc: Add new helpers to ease SMC regs manipulation
  memory: atmel-ebi: Simplify SMC config code
  memory: atmel-ebi: Stop using reg_field objects for simple things
  mfd: syscon: atmel-smc: Remove unused helpers/macros
  memory: atmel-ebi: Change naming scheme
  memory: atmel-ebi: Add missing ->numcs assignment
  memory: atmel-ebi: Add PM ops

 drivers/memory/atmel-ebi.c           | 583 ++++++++++++-----------------------
 include/linux/mfd/syscon/atmel-smc.h | 456 +++++++++++++++++++--------
 2 files changed, 532 insertions(+), 507 deletions(-)

-- 
2.7.4

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/7] memory: atmel-ebi: Add PM ops Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 3/7] memory: atmel-ebi: Stop using reg_field objects for simple things Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 7/7] memory: atmel-ebi: Add PM ops Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 5/7] memory: atmel-ebi: Change naming scheme Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 2/7] memory: atmel-ebi: Simplify SMC config code Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 1/7] mfd: syscon: atmel-smc: Add new helpers to ease SMC regs manipulation Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100
  [PATCH 4/7] mfd: syscon: atmel-smc: Remove unused helpers/macros Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-02-20 18:10 +0100

csiph-web