Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1581668

Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean

From Marek Vasut <marek.vasut@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean
Date 2017-02-15 22:20 +0100
Message-ID <tbf9w-59d-13@gated-at.bofh.it> (permalink)
References <tak1A-18Q-11@gated-at.bofh.it> <taDxg-5GH-13@gated-at.bofh.it> <taIdA-sN-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 02/14/2017 10:57 AM, Mika Westerberg wrote:
> On Tue, Feb 14, 2017 at 05:52:48AM +0100, Marek Vasut wrote:
>> On 02/13/2017 09:13 AM, Nicholas Mc Guire wrote:
>>> writeable in struct intel_spi is a boolean and assignment should be to
>>> true/false not 1/0 as recommended by boolinit.cocci.
>>>
>>> Signed-off-by: Nicholas Mc Guire <der.herr@hofr.at>
>>> ---
>>>
>>> make coccicheck complained with:
>>>  ./drivers/mtd/spi-nor/intel-spi.c:707:3-18: WARNING: Assignment of bool to 0/1
>>>
>>> Patch was compile tested with: multi_v7_defconfig (implies CONFIG_MTD_SPI_NOR=y)
>>>
>>> Patch is against 4.10-rc7 (localversion-next is next-20170213)
>>>
>>>  drivers/mtd/spi-nor/intel-spi.c | 2 +-
>>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/mtd/spi-nor/intel-spi.c b/drivers/mtd/spi-nor/intel-spi.c
>>> index 4630716..2956f2c 100644
>>> --- a/drivers/mtd/spi-nor/intel-spi.c
>>> +++ b/drivers/mtd/spi-nor/intel-spi.c
>>> @@ -704,7 +704,7 @@ static void intel_spi_fill_partition(struct intel_spi *ispi,
>>>  		 * whole partition read-only to be on the safe side.
>>>  		 */
>>>  		if (intel_spi_is_protected(ispi, base, limit))
>>> -			ispi->writeable = 0;
>>> +			ispi->writeable = false;
>>>  
>>>  		end = (limit << 12) + 4096;
>>>  		if (end > part->size)
>>>
>>
>> Looks OK, also this is the only place in the driver where writeable is
>> assigned to an explicit true/false value.
>>
>> Acked-by: Marek Vasut <marek.vasut@gmail.com>
> 
> Also
> 
> Acked-by: Mika Westerberg <mika.westerberg@linux.intel.com>
> 
>> btw the variable should be renamed from writeable to writable ;-)
> 
> It is named like that because it follows MTD_WRITEABLE flag.
> 
Now there are two things which might need fixing ^_^'

-- 
Best regards,
Marek Vasut

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean Marek Vasut <marek.vasut@gmail.com> - 2017-02-14 06:10 +0100
  Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean Mika Westerberg <mika.westerberg@linux.intel.com> - 2017-02-14 11:10 +0100
    Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean Marek Vasut <marek.vasut@gmail.com> - 2017-02-15 22:20 +0100

csiph-web